Skip to Content
avatar image
Former Member

SAP PI to IIS 7 SOAP call issue

Hi Gurus,

We have an IDOC--> PI----soap-----> Application scenario in which SAP PI sends an XML after digitally signing the XML.

It tries to establish an HTTPS connection using the server ssl certificates and also we are encrypting the request with the private key maintained in the key store.

The scenario was working fine for two months in production. Then the 3rd party application upgraded their IIS from IIS 6.0 windows 2003 to IIS 7.0 2008 and after that all the requests are failing with the error as "invalid http response: null".

I used the XPI inspector to investigate it further and looks like the handshake is happening correctly and after that when SAP PI tries to send the request, the application is rejecting the request with no response.

Please see the logs of XPI_inspector below.

socket created; additional info Sending a proxy connect request ... proxy responds: HTTP/1.1 200 Connection established proxy responds: Via: 1.1 ESD-NIE-TMG-D, 1.1 ESD-NIE-TMG-I proxy responds: Connection: Keep-Alive proxy responds: Proxy-Connection: Keep-Alive proxy responds: handshaking ... handshake done Sending a request ... connected via ssl using TLS_RSA_WITH_AES_128_CBC_SHA rebuilding the root document ... rebuilt serializing in singlepart ... serialized request message sent server responds with null Entering method with (auditLogEnabled, true) Entering method with (auditLogEnabled) Exiting method with true Exiting method with true Entering method Exiting method with com.sap.engine.messaging.impl.util.auditlog.AuditLogManager@43cff45e Entering method with (505cfdee-6a50-0a10-e100-8000ac135039(INBOUND), E, SOAP: call failed: java.io.IOException: invalid http response: null, <null>, false) Entering method with (505cfdee-6a50-0a10-e100-8000ac135039(INBOUND), E, SOAP: call failed: java.io.IOException: invalid http response: null, <null>)

I feel that there is some configuration issue in the Application end or SAP PI AIX OS is not compatible with the windows 2008 application server.

Please suggest if there is any patch which needs to be installed in SAP PI to fix this issue.

Thanks ,

Ashish

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Sep 26, 2012 at 01:54 PM

    Looks like after window server upgrades, signing and encryption logic is not in place. So though the connectivity is established the signing validation does not take place properly. Please check in that area.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Baskar Gopalakrishnan

      Thanks a lot Bhaskar,

      I will go through this document and update.

      Just out o curiosity, what are the basic difference between the ssl connection of SOAPui and SAP PI ?

      Ashish