Skip to Content

CCM4X agent getting stopped for PI711

Hi Experts,

I am facing very unique issue , where SAPCCM4X agent for statellite system PI 711 is getting stopped after some time.

while installing the agent , it was giving below error:

sapccm4x -R pf=\\XXX\sapmnt\SID\SYS\profile\SID_DVEBMGS10_SAPPIPRDAS1

Could not open the ICU common library.

The following files must be in the path described by

the environment variable "PATH":

icuuc30.dll, icudt30.dll, icuin30.dll [nlsui0.c 1610] pid = 85312

issue might because above dll files are missing from kernel directory. I have tried to deploy latest PI 711 kernel from marketplace to find above dll files. However extracted files does not show above dll. hence question of replacing kernel is discarded.

To proceed , i have copied above dll files from other server (BW 701) and placed it in PI 711 to allow to register agent.

it allowed me to register agent , but it is getting stopped after some time.

it shows status as :

INFO: CCMS agent sapccm4x working directory is I:\usr\sap\\D00\log\sapccm4x

INFO: CCMS agent sapccm4x config file is I:\usr\sap\\D00\log\sapccm4x\csmconf
ERROR: cannot open config file I:\usr\sap\\D00\log\sapccm4x\csmconf.
INFO: No agent running (no actual pid, no actual shared memory)

******** CCMS Agent is not registered  ********
******** sapccm4x Agent is not running ********

I have tried many options to rectify error like re-registering agents , checking passwrd for SAPServiceSID, clearing memory for CCMS agent etc, but it is not working.

FYI: SAPCCM4x version is 7010.0.0.192

Appriciate your help in this case.

Best Regards,

Rupali

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Sep 25, 2012 at 05:56 PM

    HI Rupali,

    From which location you are running the CCMS agent.. Please try to instal the agent from the location

    \\XXX\sapmnt\SID\SYS\exe\uc\NT*\sapccms4x pf=\\XXX\sapmnt\SID\SYS\profile\SID_DVEBMGS10_SAPPIPRDAS1

    Moreover is the CSMCONF file exist in the location where it is giving the error?

    Please try with the above..

    Thanks,

    Jagadish.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Rupali Karbhari

      Hi Rupali,

      Check the content in the csmconf file.. compare with the other servers where it deployed properly..

      It seems there is some problem with the registration..thats why the csmconf is not updated.

      Thanks,

      Jagadish.