Skip to Content
avatar image
Former Member

sapinst hangs and not launching using root user in linux

Hello Experts,

Request your help on the below issue.

We are performing a sandbox installation on a server which already has another SAP installed.

OS used :

Tool used : SWPM 1.0 SP18 used.

when we launch sapinst using root user, it simply hangs.

Please find the screenshot attached.

sapinst is working fine with my user id. But we need to perform the new SAP installation using root user.

Please advice on the issue.

Thanks and Regards,

Yuvraj H

wuead.png (19.4 kB)
dewwd.png (4.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jan 03, 2017 at 09:48 PM

    Quick question: Have you set up the DISPLAY variable correctly?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 04, 2017 at 02:02 AM

    @Reagan Benjamin, yes I have set the display variable correctly.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 04, 2017 at 07:41 AM

    Hi Yuvraj,

    can you please check your limits according to SAP Note 1704753?


    Is the temporary directory fine or out of space?


    Have you tried another SWPM version?


    Is there another OS process of sapinst running?


    Can you maybe clean the tmp directory from old trials and start SWPM again?


    Have you tried the "nogui" option just for checking?



    Please also work through SAP Note 2369910 and check your glibc versions.



    Cheers,
    Andreas

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 05, 2017 at 07:24 AM

    Hello,

    in addition to Andreas' answer, check /var/log/messages or whereever your logs go for any matching entry

    for the time where you started sapinst.

    Also, what Linux distribution is it?


    Regards,

    Hendrik

    Add comment
    10|10000 characters needed characters exceeded