Skip to Content
author's profile photo Former Member
Former Member

SAP GUI 7.20 Directory for Input History

HI,

I am setting up a remote logon session where users can access the SAP GUI. The problem I am having is that the Directory for Input History is not mapping to the folder. I have applied the following registry setting

Directory for Input History [HKEY_CURRENT_USER\Software\SAP\SAPGUI Front\SAP Frontend Server\LocalData] “DataPath” (REG_SZ) [Default: ”%APPDATA%\SAP\SAP GUI\History”] {valid path with write permission}

But the GUI is still not remembering the history of user inputs. If I manually enter the file path, the history is as normal. However I do not wish to have to manually input this file path for 200 plus users is there anyway this can be automated?

Thanks in advance for nay help!

Kind regards,

Brendon

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Nov 14, 2012 at 06:21 PM

    Hi,

    The history path depends on the operating system.

    As per note 1442303, the history path should be:

    Windows XP:

    ==========
    C:\Documents and Settings\<username>\Application Data\SAP\SAPGUI\History

    Windows Vista/7:

    =============
    C:\Users\<username>\AppData\Roaming\SAP\SAP GUI\History


    Remark: the directory for the history database can also be set to
    another default with the variable SetSapGuiHistoryDir while
    creating installation packages using the "SAP Installation Server
    Administration Tool".

    The corresponding registry key is

    [HKEY_LOCAL_MACHINE\Software\SAP\SAP Shared]"SaphistoryDir" on
    32bit operating systems and
    [HKEY_LOCAL_MACHINE\Software\Wow6432Node\SAP\SAP
    Shared]"SaphistoryDir" on 64bit operating systems

    (Type: "Expandable String Value" NOT "String" !!!).

    This folder must be writable at everytime for the affected user.

    Hope this helps.

    Best regards

    Olakunle Lemboye

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 21, 2012 at 10:53 AM

    Hi,

    If any one is interested the fix was to restrict access to the local disks on the remote desktop to prevent users saving files locally on the server. The Documents folder was then re-directed to the user’s Home Drive. This allowed the history to be saved.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 16, 2012 at 07:58 PM

    Hello Brendon,

    Would you mind recreating the issue again and uploading a frontend trace?

    To do this, start the GUI, use the ALT+F12 key combination, navigate to the Traces -> Session

    Traces, and select LocalDB, recreate the issue, and upload the files to the thread.

    Best Regards,

    Jude

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.