Skip to Content
author's profile photo Former Member
Former Member

Cannot update while another user is connect to the company

Good day,

While changing the decimal point in general setting an error occurred "Cannot update while another user is connected". To resolve the issue, we detach the database in SQL then reattached it but this resolution didn't work. I recreate the scenario in my test database and I successfully changed the decimal point. Is there any way on how to deal with this aside from detached/reattached DB.

Thank you.

Regards,

Ardie

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 20, 2012 at 06:37 AM

    Hi,

    In services.msc ---> stop sap business one event centre then update

    Regards,

    Sudhir B

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 20, 2012 at 06:30 AM

    Hi Aridie,

    Try to Logout all the user from the SAP and Try.. close all the SQL service and restart and try...😊

    Regards

    Kennedy

    Add a comment
    10|10000 characters needed characters exceeded

    • Make sure you will need to diconnect any add-on that is running as well.

      Try with super User

      According to SAP note:959777

      In 2007 A version the user will not be allowed to reduce the Decimal Places only to increase.

      If the same error pops up in the case of increasing decimal place,then make sure that no use is logged in sap b1 and then try to update

      Regards

      Kennedy

  • Posted on Sep 20, 2012 at 06:43 AM

    Hi Ardie,

    1247060 - Cannot update certain fields while other users are connected

    Symptom

    In SAP Business One release 2005 and earlier, it was possible to update all fields in Company Details and General Settings window (under Administration -> System Initialization) even if other users were connected to the company database at the same time.

    Starting SAP Business One release 2007, it will not be possible to modify certain fields such as Local Currency and System Currency (in Company Details form -> Basic Initialization tab) and Decimal Separator and Thousands Separator (in General Settings form -> Display tab) when other users are connect to the company database (via application or DI).

    If you will try to update these fields while other users are connected to the DB, an error will be displayed: "Cannot update while another user is connected to the company".

    The check if other users are connected to the database will be done based on all possible connection, meaning not only SAP Business One applications but also Add-ons and other SQL connections.


    Cause

    Consulting


    Solution

    The new behavior was introduced so to prevent change in basic definitions in the database that affects all users and all transactions that are being created.

    For example, in previous release it was possible that a certain user will modify the decimal separator in the company while other users are producing documents or performing other operations.
    As a result, it could have been that a document would be created with the wrong separator since the separator was modified during the creation of the document. This would happen since any open form will not be updated with the modifications that were done by other users.

    Thanks.

    Hari


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 22, 2015 at 11:50 AM

    I tried all solutions but they did not resolve my issue.

    Kindly do the following:

    1.Detach and then attach the database to drop connections.

    2.Stop the integration service

    3. Log in as super user.Check if the B1i user is greyed out, it should be greyed out to proceed further.If not start at (1) and restart license service.

    4.Change the Customer database to single user mode by:

    To set a database to single-user mode

    1. In Object Explorer, connect to an instance of the SQL Server Database Engine, and then expand that instance.
    2. Right-click the database to change, and then click Properties.
    3. In the Database Properties dialog box, click the Options page.
    4. From the Restrict Access option, select Single.
    5. If other users are connected to the database, an Open Connections message will appear. To change the property and close all other connections, click Yes.

    5. Log in to SAP . Stop all addons.

    6. Update number of decimals 😊 Successful.

    7.SET THE DATABASE BACK TO MULTI-USER.

    Hope you find this helpful.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 22, 2015 at 11:51 AM

    I tried all solutions but they did not resolve my issue.

    Kindly do the following:

    1.Detach and then attach the database to drop connections.

    2.Stop the integration service

    3. Log in as super user.Check if the B1i user is greyed out, it should be greyed out to proceed further.If not start at (1) and restart license service.

    4.Change the Customer database to single user mode by:

    To set a database to single-user mode

    1. In Object Explorer, connect to an instance of the SQL Server Database Engine, and then expand that instance.
    2. Right-click the database to change, and then click Properties.
    3. In the Database Properties dialog box, click the Options page.
    4. From the Restrict Access option, select Single.
    5. If other users are connected to the database, an Open Connections message will appear. To change the property and close all other connections, click Yes.

    5. Log in to SAP . Stop all addons.

    6. Update number of decimals 😊 Successful.

    7.SET THE DATABASE BACK TO MULTI-USER.

    Hope you find this helpful.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 22, 2015 at 11:53 AM

    I tried all solutions but they did not resolve my issue.

    Kindly do the following:

    1.Detach and then attach the database to drop connections.

    2.Stop the integration service

    3. Log in as super user.Check if the B1i user is greyed out, it should be greyed out to proceed further.If not start at (1) and restart license service.

    4.Change the Customer database to single user mode by:

    To set a database to single-user mode

    1. In Object Explorer, connect to an instance of the SQL Server Database Engine, and then expand that instance.
    2. Right-click the database to change, and then click Properties.
    3. In the Database Properties dialog box, click the Options page.
    4. From the Restrict Access option, select Single.
    5. If other users are connected to the database, an Open Connections message will appear. To change the property and close all other connections, click Yes.

    5. Log in to SAP . Stop all addons.

    6. Update number of decimals 😊 Successful.

    7.SET THE DATABASE BACK TO MULTI-USER.

    Hope you find this helpful.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 20, 2020 at 02:27 PM

    As per SAP Note 1247060 - THIS WORKED FOR ME

    To identify all connections that exist to SAP Business One, please use Microsoft SQL Server Management Studio (see attachment). Note that sleeping processes and also active and running Eventsender will also block the system from a successful update. • If you want to check if any client (for example, SAP Business One client, SAP HANA Studio) still connects to a SAP HANA schema to be exported, run the following SQL query in the SAP HANA Studio: • select distinct client_host, client_ip, client_pid from m_connections where connection_id > 0 and current_schema_name = ?;

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.