Skip to Content
0
Former Member
Sep 17, 2012 at 02:26 PM

SSIS BPC Make Dimesion Task fails

91 Views

Hi

I haven't heard of BPC until 2 days back.. we have an SSIS (SQL Server 2008 SP1) package failing due to 'Make Dimension Task 2008' (attached image bpc_fail.png) error.

Not much detail regarding cause of error, even after checking 'Verbose' under Reporting when executing the package.

Nothing in sql logs.

I tried changing existing user (COMPANY\OldUser) to COMPANY\User under Server\UserID within the task, but got (attached image bpc_invalid.jpg) error.

Both OldUser & User have dbo permissions on AppSet db.

AppSet is database name, right? Then how to specify server name?

Is it sql db or ssas db? Does the task use any connection manager?

I ran a trace on the server I thought it connects to and yes, the task runs.

It creates mbrPeople, dimPeople tables., updates them, then a cursor runs and then it fails without giving reason.

up_ParseMemberHierarchy - is probably the SP where it fails.

We don't know when the task ran successfully. If at all it did, probably 6 months back, because OldUser has left company (but his AD account is still active).

Any ideas.. either to fix 'Task Failed' issue or 'Invalid User or no server response' issue ?

Attachments

bpc_fail.PNG (5.7 kB)
bpc_invalid.jpg (81.8 kB)