Skip to Content

Unable to connect HANA Express VM with Eclipse IDE

Jan 03, 2017 at 05:12 PM


avatar image


I have installed Hana Express in my personal desktop, and my virtual machine is running

When i'm trying to connect eclipse it's showing that "cannot access host"

but when i am pinging with command prompt the host is accessible.

am i missing anything.?

capture.png (15.6 kB)
capture.png (9.1 kB)
capture.png (12.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Carl Soane
Jan 03, 2017 at 07:01 PM

Hello Joy:

If this is the HANA 2.0 version of Express, the default instance number is 90 not 00.



Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thank You Mr. Carl Soane. Now i'm able to connect.

Harry Jääskeläinen Jun 30, 2017 at 09:45 AM


I get the same error, but I entered the 90. Also,

on the one hand, I get the success message that all services are started, but there is no database connection. Error log:

I installed HANA Express 2.0 using the VM in a Virtual Box. I followed the provided installation guide and all checks so far went ok. E.g. accessing


from my desktop's browser shows the "up and running" info as well as all the other checks.

But: I had to create some excetions for the host so that Firefox would display the page.

I would assume a configuration error somewhere and strange is, that all services are running but no database is available. I also tried several users (HXE_ADMIN and the like), maybe that is the problem.

Many thanks in advance for a few hints. Please let me know if you need more information.

Cheers, Harry.

hana-error-1.jpg (53.2 kB)
hana-error-2.jpg (31.3 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded

Even I am facing same issue. I am able to ping the ip bu not able to connect Eclipse to HanaExpress. I checked and everything seems to be correct.if you guys found a solution for this , Please can you guys share here.




Hi Harry,

I've just solved the issue, aparently the password may be blocked

Try changin the SYSTEM user password, it worked for me

  1. su – hxeadm(hxeadm = operating system administrator)
  2. HDB stop
  3. hdbnameserver -resetUserSystem
  4. resetting of user SYSTEM – new password:(provide new password)
  5. HDB start


Eduardo Herrera