Skip to Content
avatar image
Former Member

B1if Database VERY large

Using B1 8.82 PL06 HF. The B1if database is over 50 gigabytes. The B1if log file is 8 gig. The company database is only 1.2 gig.

How did B1if get so big? We have not done any integration other than using the prebuilt dashboards that are already in SAP.

How may I reduce the size of the database? Please don't tell me to shrink the log file as it is not the problem. I have also manually deleted the message log through the framework and set it to delete daily.

I can uninstall the integration piece and reinstall, but, is it going to happen again?

Alan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 19, 2012 at 03:31 PM

    I had to reinstall the integration as none of the other solutions worked. I will monitor it to see if it grows quickly again.

    Alan

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Alan,

      In your question you mentioned that the (The B1if log file is 8 gig. The company database is only 1.2 gig.)

      So i explain you check the Database growth..

      I also  suggest you to upgarde from HOT Fix Versions...

      ..

      Regards

      Kennedy

  • Sep 16, 2012 at 04:40 PM

    Hi Alan,

    B1if file is for the integration framework of sap business one.

    So, I suggest you to check what the recovery model has been chosen for the db. I suggest you to change to simple if it is full.

    You can also remove the B1if if it is really never used and  then created again by reinstalling integration component

    Regards,

    Jimm

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 17, 2012 at 05:51 PM

    Hi Alan,

    Check: B1i Database Maintenance

    Thanks,

    Gordon

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Kennedy T

      Hi Kennedy

      where can I find this option?

      Try to clear the sap Log file by clearing the History in the administration  -- System Installation -- general setting -- Services Log History..

  • Sep 14, 2012 at 09:35 PM

    Hi Alan,

    First make a backup

    Then use this to reduce the log

    DBCC SHRINKFILE ('NAME OF THE FILE LOG', 1) -- 1 EQUAL TO 1mb

    GO

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 26, 2012 at 12:26 PM

    Hi,

    I had once the same problem. Check Your settings in B1if in Maintenance->Cfg MsgLog. You can also try to Manual Deletion. Left Range empty and it show You how much message You have stored in Your database. Then You can delete them. It should help. In that case shrinking database doesn't help.

    Regards

    Szymon

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 16, 2012 at 01:23 AM

    Hi all,

    The potential reasons:

    1.too many messages triggered. Please try to setup the event filter.

    2.too many retry attempt of failure messages. Please find the root cause of failure if you have any custom development scenario here.

    Here is some Best Practices for B1if/B1iSN DB Administration:

    • Database recovery simple
    • Setup EventFilter in EventSender.
    • Switch off message log for B1Event Monitor and Message Log.
    • Switch off producing of debugging info. Integration framework=>Maintenance=>Cft Dev env.=>Uncheck "Activate detailed log"
    • Set transaction log level to to SEVERE in xcellerator.cfg
    • By default, the system is setup to clean the log automatically, perform the log deletion by manual also help on demand clearing request:
      -Message log: Integration framework=>Maintenance=>Cft. MsgLog=>Manual/Auto delete
      -Transaction log: Integration framework=>Control Center=>Maintenance=>TLog Delete

    Kind Regards, Yatsea

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Starling,

      EventFilter in EventServer: go to (Windows) Start ->  All Programs -> Integration Solution for SAP B1 -> SAP Business One EventSender -> Setup -> Step 4/5

      or/and

      Start ->  All Programs -> Integration Solution for SAP B1 -> Integration Framework -> Maintenance-> Cfg  B1 Event Filter

      Switch off message log for B1Event Monitor: Start ->  All Programs -> Integration Solution for SAP B1 -> Integration Framework -> Monitoring -> B1 Event Monitor

      and Message Log: Start ->  All Programs -> Integration Solution for SAP B1 -> Integration Framework -> Maintenance -> Cfg MsgLog

      Set transaction log level to to SEVERE in xcellerator.cfg: I'm not quite sure, for the sake of simplicity in production env. I set all of lines in the bottom of this file to SEVERE - the whole section is named '#== Settings for the Logging: ==='

      Best regards,

      Radek