Skip to Content
author's profile photo Former Member
Former Member

Public parts not visible across SCs

Hello,

in one product we have two software components: one for COMMON functionality and another for our SERVICE. In the COMMON SC we defined our exception classes and made them available as public parts. All steps until approval have been made and the new version of COMMON was imported for development for the SERVICE SC.

Unfortunately, we are not able to reference the public part for the exception classes in the SC "SERVICE". Any idea why the public parts are not visible accross the software components?

Regards,

Volker

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 27, 2005 at 05:08 PM

    Volker,

    I don't have an answer for you but we have the exact same situation.

    The error I get when trying to create a Used DC entry pointing to the Public Part of another DC is:

    Illegal dependency: The compartment of package name(SCname...) must explicitly use compartment of ...

    The reason I've put in "..." is because the popup dialog shows only part of the error message and there is NO way to scroll through it to see it all. I'd attach a screen print but I don't know how to do it if there is a way.

    Thanks.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Kiran,

      i have got a similar problem;

      i defined DCs in a track A related to a product A and SC A and other DCs in another track B related to a product B and SC B; on my development system all was ok and all works fine.

      But when i try to import via the CMS tool the content of the track B errors occurs: 2 DCs imports from 6 DCs failed; i corrected these errors in importing and assembling the content of the track A to the consolidation system via the CMS tool without any problem;

      Then i trie to assemble components frm the track B but i received error messages: assembling failed.

      So i tried again with selct the option "Assemble even if the components are in an inconsistent state" and the assembling works fine but when i try to run my web dynpro application i have got the following error message:

      the page cannot be displayed !!

  • author's profile photo Former Member
    Former Member
    Posted on Jul 11, 2005 at 02:15 PM

    Has the SC containing the COMMON part been defined as a Usage Dependency for the other SC in the SLD?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.