Skip to Content
0
Former Member
Sep 10, 2012 at 04:17 PM

"Missing Parameter Values" - force showing prompt?

160 Views

We are using SAP Crystal Reports Server 2011 SP4 + SDK and our reports should be accessed through a managed RAS connection and displayed in a Crystal Reports Viewer Control (WIN32 VB.net application).

If we have a report with parameters, the first time we open the report the parameters prompt is showing correctly but when we close the report and try instantly again there's no prompt and we get a "Missing Parameter Values" error

If we wait some minutes it will work again.

Guess there's something not closing correctly.

The RAS log tells the following:

TraceLog 2012 9 10 16:28:11.979 2928 2804 (report:125) (..\cdtsagent.cpp:1113): JobSharing: getMatchingReportHandler: looking for metadata restriction cache entry

TraceLog 2012 9 10 16:28:11.979 2928 2804 (report:125) (..\cdtsagent.cpp:1131): JobSharing: getMatchingReportHandler: found restriction cache entry.

TraceLog 2012 9 10 16:28:11.979 2928 2804 (report:125) (..\cdtsagent.cpp:1244): JobSharing: getMatchingReportHandler: this is a datafetching action. find a prompt state.

TraceLog 2012 9 10 16:28:11.979 2928 2804 (report:125) (..\cdtsagent.cpp:1249): JobSharing: getMatchingReportHandler: found a prompt state!

TraceLog 2012 9 10 16:28:11.979 2928 2804 (report:125) (..\cdtsagent.cpp:1261): JobSharing: getMatchingReportHandler: promptstate says we need parameters!

TraceLog 2012 9 10 16:28:11.979 2928 2804 (report:125) (..\cdtsagent.cpp:3432): CDTSagent::doOneRequest reqId=351: CSResultException thrown. ErrorSrc:"Analysis Server" FileName:"..\cdtsagent.cpp" LineNum:1263 ErrorCode:-2147217394 ErrorMsg:"" DetailedErrorMsg:""

How to force showing the prompt?

Any help is much appreciated.

B. Meier