Skip to Content
0
Former Member
Aug 31, 2012 at 07:20 PM

Missing Constraint: Import-Package: com.sap.engine.lib.xml.parser.tokenizer;

30 Views

Hello experts

I am trying to install SAML2 on LJS version 0.5.12. hit following error message. Does anyone know where I can get this required jar file.

Thanks

osgi> install file:C:\Users\i813816\Downloads\LJS\saml2.api-1.2.1\bundles\com.sap.security.saml2.cfg-1.2.1.jar
Bundle id is 231

osgi> start 231
org.osgi.framework.BundleException: The bundle "com.sap.security.saml2.lib_1.2.1 [232]" could not be resolved. Reason: Missing Constraint: Import-Package: com.sap.engine.lib.xml.parser.tokenizer; version="0.0.0"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1327)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1311)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:291)
at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:333)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:209)
at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:155)
at org.eclipse.osgi.framework.internal.core.FrameworkConsole.runConsole(FrameworkConsole.java:140)
at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:104)
at java.lang.Thread.run(Thread.java:662)

osgi>