Skip to Content
avatar image
Former Member

sapcpe.exe in red after application server installation

Hello

We are trying to obtain access to a remote MS SQL Server database from our SAP Netweaver 7.0 EHP 2 in our develop environment. Our platform is with Oracle 11.2.0.2 as RDBMS and AIX 7.1.0.0 as OS.

We are installing a new application server to make our BI system able to access the mentioned database. The new dialog instance server is a VMWare VSphere 4.1 partition with Windows Server 2008 R2 server as OS. We execute sapinst and the installation process starterd and installed the D00 instance, but when the installation process execute the step that start the dialog instance, it shows a error message. We checked the log files and the SAPMMC and we could observe that the SAPCPE.EXE cannot start and is showed in red and the disp+work is showed in gray. The dev_dp file shows this message:

***LOG CPS=> DpLoopInit, ICU ( 3.4 3.4 4.1) [dpxxdisp.c   1638]

***LOG Q1K=> MsIAttachEx: StoC check failed, Kernel not compatible with system (rc=29) [msxxi.c      817]

*** ERROR => not allowed to connect to message server via port 3900 [dpxxdisp.c   12195]

*** ERROR => Please check your configuration (profile parameter rdisp/msserv_internal) [dpxxdisp.c   12196]

DpHalt: shutdown server >CMIBI70DIA_BI1_00                       <

(normal)

DpHalt: stop work processes

Viewing that message, we updated the kernel to 300 level in both systems. After the upgrade, the central instance started without troubles, but the dialog instance remains with the error. In fact, the SAPBI_00 service cannot start. If we put back the old kernel, the service can start and the error message remains.

Also, we can access the AIX environment through Samba and the installation program wrote without problems the dialog instace profile on the /sapmnt-/SID/profile directory.

We checked the installation guide and this OSS notes list to validate the errors showed:

Note 1112809 - INST 7.10: Appl.Server in Heterog. SAP System Environment

Note 28781 - Central transport directory NT/UNIX

Note 684106 - Microsoft runtime DLLs

Note 680617 - INST: Appl.Server in Heterogeneous SAP System Environment

We followed all the instructions that the notes indicates and that corresponding to our environmet.

The installation process stopped and the instance still doesn't start.

Any ideas?

Felix

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 19, 2012 at 03:06 AM

    I've found the solution. I downloaded again the kernel because, aparently, some files were corrupted. Also, I unzipped manually the sapcryptolib files and put them on the corresponding folder. I think could be a installation problem.

    Case closed.

    Thanks all for your comments.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 29, 2012 at 02:09 AM

    In the dialog instance host , please check in the services file the entry below exists

    sapms<SID>     3600/tcp

    Also in the DEFAULT.PFL ,

    enter the parameter rdisp/msserv_internal = 3900

    Regards

    Ratnajit

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Nicholas Chang

      Hi Nicholas

      The start profile indicates that the parameter is pointing to the right path:

      DIR_CT_RUN = $(DIR_EXE_ROOT)\$(OS_UNICODE)\NTAMD64

      Regards,

      Felix