Skip to Content
avatar image
Former Member

Deactivate SAPGui security notification when taking a screenshot

Hi Gurus,

I have enhanced the popup notification to attach it a screenshot of the top front transaction used by the user. To do this, I'm calling the method CL_GUI_FRONTEND_SERVICES=>GET_SCREENSHOT.

Everything is working fine except that I always get a popup asking me if I allow or deny the server to take a screenshot of the active SAP window ? (see attached picture).

Is there a way to not get this popup and always allow the screenshot ?

From business perspective, it is really boring to ask user each time to agree because we now that he will always agree.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Aug 25, 2012 at 01:52 AM

    I do not know if your can disable the security pop for your specific request.

    You can disable popups globally (http://scn.sap.com/thread/2067201).

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 25, 2012 at 09:42 AM

    hi Frederic,

    the below links might be helpful to set the SAP Security option.

    Popup Option

    For more info.

    Security Guide

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 12, 2014 at 11:35 AM

    Hi Frederic,

    The OSS note 1835429 - Security message for CL_GUI_FRONTEND_SERVICES->GET_SCREENSHOT  explain that's this popup is required for "privacy reason" and there'is no way to deactivate it !

    Regards

    Eric

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 12, 2014 at 06:35 PM

    Hi,

    You can turn this message off by using the Customize Local Layout (ALT+F12) and clicking OPTIONS.  Select "Security Settings" from the "Security" folder.  In the "Security Module" frame, select "Disabled".

    Hope this helps!

    Chip

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 22, 2014 at 11:14 AM

    After looking through the Security Guide and determining the options available, I threw a test installer script together and tested in a VMWare enviroment on a Windows XP machine. (32bit)

    Under HKEY_LOCAL_MACHINE\Software\SAP\SAPGUI Front\SAP Frontend Server\Security, I added 2 registry entries at the end of the install.

    DWORD key SecurityLevel with a value of 0 to deactivate

    DWORD key DefaultAction with a value of 0 to allow

    I left the rest of the options alone and ran a fresh install using these values on a clean image.

    I never changed the option and it was automatically set to disabled.  I also ran a few BEx Queries, which is where most complaits came from in our testing lab.  I have yet to see the pop up.  Obviously we do want some security but this is just in testing currently and I wanted to see if it could be stopped altogether.  Without performing addtional more thorough tests, this looks as if it may work.  Goodluck.

    Regards,

    Nitish Kotak

    Also... for a 64bit OS it will have to be changed under

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP\SAPGUI Front\SAP Frontend Server\Security

    Add comment
    10|10000 characters needed characters exceeded

  • May 22, 2014 at 04:58 PM

    Hello,

    The Method GET_SCREENSHOT of class CL_GUI_FRONTEND_SERVICES is contained by SAP GUI in the security module and will "always" return the explicit question to the user : "The server is trying to take ... do you want to allow it?"

    You can test that method in transaction SE24 -> CL_GUI_FRONTEND_SERVICES => Execute -> GET_SCREENSHOT => execute

    That rule is installed permanently in the SAP GUI security module and cannot be inactivated on the client. This response was actually implemented based on customer feedback.

    Thanks ad regards,

    Eric Van de Catsije

    NW Clients Moderator

    Add comment
    10|10000 characters needed characters exceeded