Skip to Content
0
Aug 23, 2012 at 11:05 AM

Full milage reimbursement + private car bug FITE_VC_REVIEW

28 Views

Hi folks,

System: ECC 6.0 EHP 4 SP 51 Stack 11.

for about one week (after the update to SP51/Stack11) I'm facing the following problem in the Travel Request WDA Scenario:

I select the requested transport "PPKW" which is configured as private CAR in IMG.

I select "GWE" for full milage reimbursement.

When I navigate forward to FITE_VC_REVIEW, I get the error "Full mileage reimbursement is granted only for requests with private car" from PTRA_WEB_INTERFACE Number 234.

I've debugged and found out the following:

Whilst navigating forward, the form routine "check_trans_accom_categ" within FM "LPTRA_UTIL_GENERAL_DATAF01" is called three times. The first two times, the check passes, the thrid time, however, the form routine fails to check against the requested transport devices because the ind_requested column seems to have been cleared for some reason and the program tries to read an entry from the table with key ind_requested = x, which inevitably fails.

SAPxSearch and SapNoteSearch don't provide any help to this system behaviour.

I've done no modifications and switched off all my enhancements to make sure I didn't cause this. Is anyone who has the same system status as me able to reproduce this error? At the moment, this looks like a program error in the standard to me. If I don't hear back from anybody until the end of the day, I'll raise a message :-/

Edit: I raise a message in parallel after all because this is somewhat urgent.

Any help is appreciated.

Cheers, Lukas

Message was edited by: Lukas Weigelt