Skip to Content

ABAP dataflow not working

Hi,

We are having problems getting a very simple ABAP dataflow working and was hoping someone can point us in the right direction. We have a connection to our ECC system setup and we are using the "Shared Directory" as the data transfer method. We then created a very simple ABAP dataflow to extract from LFA1 table to test, we keep getting the error: "Execute ABAP program <//ServerName/BDD/Test.abp> error <Open File Error -- \\ServerName\BDD\Test.dat>.

What is strange about this is the file "Test.abp" was created in the specified directory, however when I open up the file expecting to see actual data I am seeing what looks like ABAP codes (I am posting a snippet of the file below):

REPORT ZAL_ABAP message-id 26 line-size 255
no standard page heading.
* Z_LynneTest.
PARAMETER DOWNLOAD(1) DEFAULT 'N' lower case. "N-svr,Y-clnt
PARAMETER EXECMODE(1) DEFAULT 'D' lower case. "D-dlg,B-btch
PARAMETER OUT_DIR(48) DEFAULT "output file dir
'\\SAPFSTEST\SAPSHR\BDD\ECC_Data' lower case.
PARAMETER IN_DIR(48) DEFAULT "input file dir
'\\SAPFSTEST\SAPSHR\BDD\ECC_Data' lower case.

PARAMETER P_DF_VK(40) DEFAULT "ABAP data flow object key
'' lower case.
PARAMETER P_DI_GEN(40) DEFAULT "DI version that generated ABAP
'' lower case.

*** Machine generated ABAP. Do not modify. ***
*** (C)Copyright Business Objects S.A. All rights reserved. ***
*
* Date Time:
* 08/22/12 15:30:41
* SAP used for generated this ABAP:
* Release: 702
* Host :
*
* ABAP Dataflow Name:
* Test_ABAP
* ABAP program name in SAP:
* Z_TEST
* Generated ABAP file name:
* //ServerName/BDD/Test.abp
TABLES LFA1.

DATA: begin of ITAB2 occurs 0,
LIFNR(10) TYPE C,
NAME1(35) TYPE C.
DATA: end of ITAB2.

data: append_flag(1) value ' ',
cntbuf type i,
delimleng type i.

CONSTANTS C_DF_VK(40) VALUE '2458'.
CONSTANTS C_DI_GEN(40) VALUE '14.0.2.376'.
DATA WARN_MSG(50).

start-of-selection.

PERFORM FORM2.
PERFORM FORM3.
FREE ITAB2.

....

....

Has anyone run into this problem before? and most importantly how do we correct this? Is it a permission problem ???

Thank you so much for your help in advance.

Lynne

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Aug 23, 2012 at 06:10 AM

    Hi Lynne

    This issue relates to the permission problem.

    Refer the below document.

    http://scn.sap.com/docs/DOC-30330

    I have mentioned the issue there

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.