Skip to Content
avatar image
Former Member

Bold Text for header not coming in Smartform

Dear Experts,

I have got smrtform for changes. They wanted some fields to be added. Now the problem is after adding header text which were in BOLD are getting displayed as BOLD. I passed the style created for the smartform

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

9 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 20, 2012 at 12:47 PM

    Hi Swarna,

    in smart style give paragraph format p1 and font style is bold and indents and spacing is centered.ass the smartstyle name in smartforms output options.now select the content that should be displayed as bold and give the name of the format p1 (character or paragraph) in styles.

    find below screen shot.

    thanks,

    marimuthu.k


    pastedImage_0.png (43.9 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2012 at 11:00 AM

    Hi Swarna,

    Just one more time check the smart style what you have created already and check the style(paragraph format and character format) assigned to that particular header text element in smartform.

    Thanks,

    Bharathkumar.MG

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 20, 2012 at 11:39 AM

    Hi,

    I think you have to check the font which is define as already bold or not. You are assuming bold with type but it should have been installed on the system with bold characterastic.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2012 at 11:53 AM

    standard is <h> or <b> i think

    best regards

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2012 at 12:05 PM

    if still the problem is not getting solved.

    then download the smartform in XML format on ur pc.

    and share it on sdn.

    we will try to find out whats bothering you.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2012 at 12:11 PM

    Hi Swarna,

    please check the smartstyle once again that font style is bold or not and also check standard paragraph. Finally activate the smartstyle and pass the smartstyle name in smartforms output options.now select the content that should be displayed as bold and give the name of the format (character or paragraph) in styles.

    thanks,

    MARIMUTHU.K

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2012 at 12:34 PM

    Thanks all for the response and i am extremly sorry as by mistake the half of my querry got posted to this forum as when i tried to save this into draft. I tried to edit it, still failed. I am sorry for this.

    My problem is the smartform which i have got for change, the header text initially were coming  as BOLD. After adding the required fields into it, it's not coming properly. In the change editor i passed the correct character format for this.

    Eg : The Style created for this, has the Character Format as K for BOLD and Paraghaph format CE for center. so i passed in the change editor as for CE <K> Item Number </>

    I don't really understand why it is not taking the BOLD format.. I activated the Style and the smartform as well.. I tried creating a new character format and passed. Still the same error is occuring. Can any one please suggest me what exactly can be the problem.

    Thanks and Regards,

    Swarnadeepta.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear,

      please delete that text node and insert new text node with same data and give paragraph style ce and select that text or variable and assign charcater style k.

  • avatar image
    Former Member
    Aug 20, 2012 at 01:41 PM

    hi ,

    please try the following.

    click editor in text editor.then click ->go to->change editor->left most corner give the format name like p1 and don't forget to activate both smartstyles and smartform.

    thanks,

    MARIMUTHU.K

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2012 at 06:55 PM

    Hi all..

    I don't know how .. but my problem got solved.. 🤣

    i was working on Chinese fonts.. So in the smartstyle i changed the font-type from Helves to CNSONG.. and after the NACE configuration and translation in the se 63 (lang from English to Chinese ).. when i executed the transaction the form was coming absolutely fine as per the requirement .. but the question.. still remained the smae .. Why was it not working earlier and why it is working fine now.. Anyway.. the problem got solved .. if anyone finds any answer to my querry please respond.. Thanks all once again for your kind support. 😊

    Regards,

    Swarnadeepta .

    Add comment
    10|10000 characters needed characters exceeded