Skip to Content
avatar image
Former Member

You are not authorized to logon to the target system......

Hi

We are supporting a real old ITS application  (46DC4.387209). This has been working fine talking to a 4.0b SAP system. After many happy years of working we now have a problem. When we access the login screen for the web application on the Wgate we see the message  "You are not authorized to logon to the target system." before anyone enters a user account or a password.

Even though the Agate service is running on the server we get this message repeating in WGate.trc

 

08/16/2012 10:41:51.192 p003432 t5808 [w3xxwgct.c, 1978]: *E* WgCtAssignAGate: There is no available AGates in instance "PRD01" to serve the request

08/16/2012 10:41:51.192 p003432 t5808 [w3xxwgct.c, 1471]: *E* WgCtDo: WgCtAssignAGate() failed, rc=3

08/16/2012 10:41:52.270 p003432 t5808 [w3xxammc.c, 923]: *E* AmmcConnectChannel: NiSnc2Connect(3900) failed, rc=-10

08/16/2012 10:41:52.270 p003432 t5808 [w3xxwgct.c, 1490]: *E* WgCtDo: Connect to AGate 10.40.64.218 failed, instance PRD01, rc=0x61ff, nrc=-10!

08/16/2012 10:41:52.270 p003432 t5808 [w3xxwgct.c, 1978]: *E* WgCtAssignAGate: There is no available AGates in instance "PRD01" to serve the request

08/16/2012 10:41:52.270 p003432 t5808 [w3xxwgct.c, 1471]: *E* WgCtDo: WgCtAssignAGate() failed, rc=3

In AGate.trc we get this message repeating.

 

08/16/2012 09:17:03.832 p0000042C t1528: *E* MprfCheckFbName: RfcCallReceive() failed!, function = ITS_LOGIN_CHECK_RFC, msg = You are not authorized to logon to the target system.

08/16/2012 09:17:03.832 p0000042C t1528: *E* MprfValidLogin: failed!, msg = You are not authorized to logon to the target system.

08/16/2012 09:20:33.176 p0000042C t1528: *E* MprfCheckFbName: RfcCallReceive() failed!, function = ITS_LOGIN_CHECK_RFC, msg = You are not authorized to logon to the target system.

08/16/2012 09:20:33.176 p0000042C t1528: *E* MprfValidLogin: failed!, msg = You are not authorized to logon to the target system.

We have tried making sure the GLOBAL.SRVC password (DES26 encrypted) match the SAP user password for the account that accesses SAP.

Anyone out there had this problem before?

We cant get into ITS administration either.

Thanks

Matthew

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Sep 04, 2012 at 04:38 PM

    Hi Matthew,

    The wgate traces could also show a resource issue. Are there available workthreads or sessions on the agate instance PRD01 when you get these error messages?

    What are the results if the same user trys to access the R/3 via the SAPGUI?

    Are they part of a logingroup?

    What is the service being accessed?

    What are it's settings in the xxxx.srvc file?

    The ITS Admin - why can it not be accessed? Do you get the logon page? Is the user and password not working?

    Regards,

    Oisin

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Turned out to be a password issue. When we finally found a way to get the encrypted password into the .srvc file it all started working again.

      Thanks for the reply