Skip to Content
avatar image
Former Member

STAT files is growing rapidly after Kernel & Patch upgradation

Hi Team

We have recently upgraded our system from patch level 701 SP 8 to 701 SP11 & kernel 701 SP 176 to Kernel 720 300 ( OS REHL Linux& Oracle 11g). After upgradation stat file under FS /usr/sap/<SID>/DVEBMGS<NN>/data is growing rapidly. Below are for example.

Before patching

-rw-r--r-- 1 <sid>adm sapsys    1283281 Aug 14 03:00 stat629

-rw-r--r-- 1 <sid>adm sapsys     876147 Aug 14 04:00 stat630

-rw-r--r-- 1 <sid>adm sapsys     874191 Aug 14 05:00 stat631

-rw-r--r-- 1 <sid>adm sapsys     873124 Aug 14 06:00 stat632

-rw-r--r-- 1 <sid>adm sapsys     893806 Aug 14 07:00 stat633

-rw-r--r-- 1 <sid>adm sapsys    1531792 Aug 14 08:00 stat634

As avg each file is around 2 to 3 MB

After Patching( SAP_BASIS 701 SP11, Kernel 720 SP300 on Linux & Oracle 11g)

-rw-r--r-- 1 <sid>adm sapsys  60158401 Aug 14 14:00 stat130

-rw-r--r-- 1 <sid>adm sapsys  41166893 Aug 14 15:00 stat131

-rw-r--r-- 1 <sid>adm sapsys  23010130 Aug 14 16:00 stat132

-rw-r--r-- 1 <sid>adm sapsys  23725072 Aug 14 17:00 stat133

Avg each stat file is 20 to 60MB.

I have  gone trough OSS note 6833 but did not find how can i control size of stat file. As per this note i can only reduce the log time period of stat files using parameter stat/max_files.

Can anyone please help me to resolve this issue

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Aug 15, 2012 at 01:52 AM

    Hello,

    The number of stat files on the system is set with parameter stat/as_max_files. By default it is 48 and if you reduce it you will have less data to analyze on STAD transaction. If you also wants to reduce the number of files on the OS you can set the stat/max_files to 24 for example.

    To reduce the size of the stat files you can set parameter stat/rfcrec to 1. You can take a look on SAP note  552845 for more information.

    Regards,

    David

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 14, 2012 at 05:03 PM

    You cannot reduce the size of the files.  You can control whether to the system can generate them or not.

    Set the value of the parameter (stat/max_files) to a lower number and also include the parameter (stat/compression).  You can also specify a different location (stat/file) for the STAT file if you are concerned about disk space.

    http://help.sap.com/saphelp_nw70/helpdata/en/af/59f23a4453c316e10000000a114084/content.htm

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 14, 2012 at 05:22 PM

    Hi,

    You might also want to take a look why these files are suddenly growing rapidly. Check tcode STAD and investigate if you see unusual excessive behavior for any specific user id.

    Regards,

    Samik

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 15, 2012 at 04:00 AM

    The growth rate of the statistics file is dependent on the workload of the system. Also 20-60 MB is quite acceptable , but the fact remains why did it grow so much as compared to before . Were you running SGEN , when you collected the data that you have pasted . Did you see a huge load on the system ?

    I believe you performance collector job is scheduled hourly , so that the stats file content is moved to database.

    Regards

    Ranajit

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Thanks for your Reply!!

      I have  stopped all SMD agent but nothing change still huge stat file logs is generating.

      Can we have any other option to analyze this issue.