Skip to Content

maxdb autosave not working

I have a strange problem wih autolog since moving one of our databases to multiple log partitions (used this wiki http://wiki.sdn.sap.com/wiki/display/MaxDB/HowTo+-+Usage+of+Multiple+Log+Partitions )

Setup is now 2 log partition , one log each , one log queue per log partition.

param_getvolsall log

OK

UseMirroredLog NO

MaxLogVolumes 4

LogVolumeName001 1024000 F /log/EPR/saplog/DISKL001 1

LogVolumeName002 1024000 F /log/EPR/saplog/DISKL002 2

As the we rely on timely log backups we normaly use the autolog feature with time interval to create a new log every 10 minutes (this feeds a remote standby database)

Now even with autolog properly set to on, and the system shows its on, no log files are generated anymore since we did the switch

info log

Name | Value

Log Mirrored = NO

Log Writing = ON

Log Automatic Overwrite = OFF

Max. Size (KB) = 16350176

Backup Segment Size (KB) = 2730664

Backup Interval (seconds) = 600

Used Size (KB) = 63720

Used Size (%) = 0

Not Saved (KB) = 63720

Not Saved (%) = 0

Log Since Last Data Backup (KB) = 0

Savepoints = 144513

Checkpoints = 0

Physical Reads = 138323

Physical Writes = 1063454

Queue Size (KB) = 16000

Queue Overflows = 0

Group Commits = 0

Waits for Logwriter = 336835

Max. Waits = 5

Average Waits = 0

OMS Log Used Pages = 0

OMS Min. Free Pages = 0

I can do manual log backups if i disable autolog , but that is not as nice as during data backups this is not possible (autolog normaly works also during a data backup)

There are absolutely no error messages in the dial files , so not sure what is going on.

When i switch logging on (either via command line or gui) i can see a message in the krenel message file like :

KnlMsg: PARAMETER="AUTOSAVE"

KnlMsg: <MSG _NO="1" _ID="52104" _COMP="AUTOSAVE" _TEXT="standby mode on">

KnlMsg: _LABEL="AUTOSAVE"

I see savepoints generated every 600 seconds, but then no log is created.

I have a feeling it is related to anothier issue after this change and that is that on the standby database, although these log apply perfectly well, there seems to be no Db timestamps anymore in these log files . Example of a log check :

OK

Returncode 0

Date 20120813

Time 00114015

Server erpsap-101

Database EPR

Kernel Version Kernel 7.8.02 Build 023-121-242-871

Pages Transferred 6944

Pages Left 0

Volumes 1

Medianame LOG_RESTORE_MEDIUM

Location /backup/EPR/EPR_LOG_L.28298

Errortext

Label LOG_000028298

Is Consistent

First LOG Page 526020119

Last LOG Page 526027042

DB Stamp 1 Date 00000000

DB Stamp 1 Time -0000001

DB Stamp 2 Date 00000000

DB Stamp 2 Time -0000001

Page Count 6924

Devices Used 1

Database ID erpsap-101:EPR_20110225_232652

Max Used Data Page

Converter Page Count

Maxdb Version : 7.8.02.23 on Linux OS

Any ideas ??

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Aug 21, 2012 at 01:31 AM

    Hello,

    I hitted the issue already known & reported in PTS # 1241024:

    http://maxdb.sap.com/webpts?wptsdetail=yes&ErrorType=0&ErrorID=1241024

    Automatic log backup does not work as expected if 
    - more than 1 log partitions are defined
    - a time interval is defined for the automatic log backup.

    In this case the log is only saved at the specified time interval if a log segment is
    completely filled. In case the log segment is not filled the given time interval has no effect.

    this issue is fixed as of 7.8.02.29 DB version.

    Regards, Natalia Khlopina

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 13, 2012 at 12:50 PM

    Can anyone guide me the procedure of setting up DR with maxdb please. as i am new with maxdb.

    Suse linux 10

    Maxdb: 7.8

    is there any way we can do that ?

    Appreciate the positive Answer

    Thanks

    Omar

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 19, 2012 at 09:54 PM

    Anyone any ideas ?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.