avatar image
Former Member

Error during Activation

Hi SDI community, I'm trying to create my own SDI replication following SPS09 video.

I'm getting following error when I try to activate my procedure.

"info Activation is performed with activation mode cascade one-phase. info Runtime 'Flowgraph runtime' finished activation of 1 object(s) in 2488ms error SDI_HANA:RealTime_BS1.hdbflowgraph column not allowed: "MANDT" in select clause"

Any clue of what could be wrong??

By the way, I had to add Write type Insert to avoid error 140004] scenario -> DATA_2 - No primary keys were found in target table

Thank you all!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jan 04, 2017 at 12:22 AM

    Hello Ariel,

    can you please share some more information on the flowgraph that you are trying to activate?

    From which source are you reading and are you replicating into an Hana Table or into a Virtual Table?

    Also if you are following the SPS09 videos you are using Hana Studio, correct? Can you please use the web based editor and try it in there?

    PS: The Writer Type is necessary as in realtime tasks all rows coming in will have an operation code (insert, update, delete,...) which can only be performed on the target if we know a primary key in the target table. By selecting insert it will map all operations to an insert.

    Thanks and Best Regards,

    Timo

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Timo,

      I am facing the same issue that Ariel had mentioned. Here are the details of the flowgraph I am trying to activate..Please note that same issue appears in both HANA Studio & Web based editor.

      Issue: Error while activating /abc/xyz/REALTIME_ECA_ABAP.hdbflowgraph:

      [abc.xyz:REALTIME_ECA_ABAP.hdbflowgraph] column not allowed: "SNO" in select clause

      Note: "SNO" is a primary key

      Source: ECC on ASE using ABAP adapter

      Target: HANA Cloud {HANA table as target (Data Sink) or HANA Template Table created via flowgraph}

      Could you please let me know how to overcome this issue?

Skip to Content