Skip to Content
author's profile photo Former Member
Former Member

Parameter ID not showing in Z-Report

I've a Z-Report with Controlling Area and Plant as the selection.

Controlling Area has parameter CAC

Plant has parameter BWK.

Thus i proceed to set the default value at SU01 > Parameter tab.

But the default value are not shown there.

Kindly advise

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 02, 2012 at 03:16 AM

    PARAMETERS: p_con TYPE KOKRS MEMORY ID cac.

    This will get you the controlling area.

    Thanks,

    Shambu

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 02, 2012 at 03:56 AM

    Hi Chin Joo Neo,

    Use GET PARAMETER at initialization.

    Example:

    PARAMETER yourfield TYPE MARC-WERKS.

    INITIALIZATION.
    GET PARAMETER ID 'WRK' FIELD yourfield.

    Note: the set parameter will be changed if the user changed the value last in another transaction. You could reset it with SET PARAMETER after they changed the value back.

    Regards,

    sifter


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.