Skip to Content
0
Former Member
Jul 31, 2012 at 02:37 PM

User defined dimensions and the %{dimname}_set% variable

245 Views

Hi everyone,

I'm trying to run logic where the user must select a value in the package at runtime, but it is a user-defined dimension, so I can't use the %ENTITY_SET%-type variables in my script.

This is from a (very) old script logic guide:

The Keyword %{DimName}_SET%

An implied keyword is available for each dimension. This keyword will hold the set of members passed to the logic engine for a give dimension. This keyword can be used as a replacement string to use anywhere in the logic.

The syntax is: %{DimName}_SET%

Can anyone verify whether the above is still true? And if so, what goes in the {DimName} argument? I tried this with my actual dimension name, and it didn't work. I've tried looking in the log files to see where these values are passed, but I couldn't see anything useful.

I'm really hoping someone can answer this, as otherwise I am going to need to make big changes to my applications in order to make this dimension a "standard" type dimension.

Thanks a lot folks.

Cheers,

Jason