Skip to Content
author's profile photo Former Member
Former Member

How to display 0PERS_SAREA personnel subarea code (deleting personnel area code)

Hello everybody!

I have a report in which I must show Personnel Area (0PERS_AREA) and Personnel Subarea (0PERS_SAREA). The problem is that as P. Subarea is related with P. Area, the Subarea char shows the Area code as well, I mean, for example, a P. Subarea is code AT880 and its related Area is IAME. In the report, when showing P. Subarea, it shows IAME/AT880 instead of just AT880.

Do you know how can I do to remove that 'IAME' part from P.Subarea characteristic? Is it possible to do it at query level or should I do some modifications in data flow below?

Thanks in advanced!

Alberto

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2012 at 11:42 AM

    Hi Alberto,

    Yes If Area is the compounding attribute of Subarea, you can hide it from being shown in query.

    All you have to to is to modify the query like below.

    1. Drag and Drop the object Personnel Area (0PERS_AREA) in the rows.

    2. Change the display property of this object as 'No Display'. And this will hide the area value.

    Now the Subarea will be displayed as AT880.

    Hope this solves your issue.

    Regards,

    Jeevitha

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Actually 0PERS_SAREA is not compounded with 0PERS_AREA. It's a bit extrange indeed. I'm running the query with BEx Analyzer, both chars are defined as Free Characteristic.

      If I display 0PERS_AREA first and then 0PERS_SAREA, values are correct, but in the moment I remove 0PERS_AREA, the other characteristic becomes compunded.

      For example

      0PERS_AREA = IAME

      0PERS_SAREA = T808

      Displaying first _AREA and then _SAREA:

      IAME T808 -> Correct

      Displaying first _SAREA or removing _AREA from the above example:

      IAME/T808

      Anyway, I solved it creating a new CHAR using as template 0PERS_SAREA with the difference that in "Relation" tab I've deleted the relation with 0PERS_AREA, I've filled this Z char with 0PERS_SAREA in the transfer rule and now it's working fine (just texts are not showed, I'll figure out how to solve it).

      Thanks for your help!

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.