Skip to Content
author's profile photo
Former Member

SAP BW DBConnect datasource issue

Hi Experts,

We have done the upgrade from BW 3.5 to BW 7.3 in the Dev system after the system copy to a new environment. And once the upgrade is over, we were checking the data loads and found that all the dbconnect datasources are not working. I have verified that source system connection for the non-SAP system is establisjed and connection is also fine. And also, the user id and password which is specified in the source system connections has the respective access to read the views/tables and to fetch the data from the non-SAP source system.

DB team also showed me that when they logged into BW Dev through OS level-> then from there, logged into the source system's user id and password -> then tried to read the data from the views. And, this approach gave the results. Only the difference in this approach is they have not gone via source system connection which is established in BW Dev instead they logged into BW Dev and directly jumped to the respective source system through the credentials.

When checked the database tables(RSA1->Source Systems->Select Database Tables) in the new Dev, it displayed all the tables and views similar to the old Dev. However, if I try to edit the datasource by double-clicking on the view name, it didn't show even a single field which is present in the view(instead it is showing me the zigzag symbol). I have tried re-generating the datasource. And, also tried deleting the transfer rules, deleting the datasource and then re-generating the datasource again. But both didn't help out.

Kindly help me out on this issue as it would be very much helpful for us to resolve it at the earliest.

Thanks in Advance,

Regards,

Yokesh Kumar.

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • Posted on Aug 17, 2012 at 03:51 AM

    Hi

    DB connect source system some times will give this type issues, even all the connections are in place also will face. only way to resolve the issue is please ask Basis team to rebuilt the connection to DB connect and check.

    Jagadeesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      1. Make sure that the affected DataSource is not assigned to an active RDA daemon in the RDA monitor (transaction RSRDA).

      2. Execute report RSAR_PSA_NEWDS_MAPPING_CHECK in transaction SE38 to identify and repair inconsistencies in the PSA metadata.

      3. (Re)activate the affected DataSource.