Skip to Content
0

Can't bind data to basic component in Design Studio 16.3.1

Jan 02, 2017 at 10:40 AM

251

avatar image
Former Member

Hello and a happy new year!

I want to display real time values from a streaming data source in text components. Unfortunately the data binding colum is simply missing in the properties pane.

(Also, there is not that arrows-button next to the "Pins this property view to the current selection"-button which seems to have been there in earlier versions to enable the data binding column, as presented here: https://archive.sap.com/documents/docs/DOC-64301).

This issue arises on my development server, where Design Studio 16.3.1 is installed. On my local laptop installation I have DS 16.3.0 and the data binding column is visible.

So is this a bug in 16.3.1 or am I potentially missing something? Is this already fixed in a newer version of Design Studio or would I have to downgrade to be able to bind data to basic components?

Thank you very much for any thoughts upon how to best solve this!

Daniel

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Best Answer
Tammy Powlas
Jan 04, 2017 at 10:24 AM
0

Daniel - what do you mean by HANA mode? Is HANA your deployment platform? If so please see https://blogs.sap.com/2015/11/09/the-future-of-design-studio-platform-development/

Have you considered updating to SP4 for Design Studio?

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Evidently, this is exactly the cause of the dilemma. I was now referred to this Knowledge Base Article by support, stating most of those restrictions in HANA mode:

https://launchpad.support.sap.com/#/notes/0002374582

0
avatar image
Former Member Jan 02, 2017 at 01:56 PM
0

I realize now the binding column (and also many more components) is available also on the development server if I open Design Studio in local mode instead of HANA mode. So it is HANA mode that is preventing me from being able to bind data to basic components.

I have tried to find any information on what might be wrong in my configuration in the manuals and forums, but up until now I can't find any solutions.

Any ideas what might cause the modes to differ with respect to what components are available and what their functionality is?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 04, 2017 at 08:38 AM
0

Hello again,

I would really hope somebody can help me here soon. I am not able to find a solution.

The only thread I found discussing a similar (but possibly very different) kind of issue is this one with the title "Locally it works, from HANA it doesn't":

https://archive.sap.com/discussions/message/16095202#16095202

This thread suggests to me, that something might be wrong with the Design Studio add-on in HANA. So I asked my admin to reinstall it and to make sure that "Overwrite inactive version" and "Activate objects" are ticked while importing the HCOBIAAS.tgz file (HCOBIAAS03P_1-70001186 was used). Unfortunately this did not help at all and I am now really riddled with what the problem might be.

I show you how Design Studio looks to me in Local Mode and HANA mode.

Local Mode, the binding column is available:

HANA Mode, the binding colum is missing and I have less components available:

Please, are there any suggestions or recommendations? Any more information I should provide you with or is there something I can check to pin down the issue?

Thank you!

Daniel


local-mode.png (58.5 kB)
hana-mode.png (58.7 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 04, 2017 at 11:13 AM
0

Hi Tammy,

thank you for your reply!

By "HANA mode" I mean that I have set Preferences -> Application Design -> Preferred Startup Mode -> SAP HANA, and I guess that makes it my deployment platform?!

Do you mean to tell me that "newer functionality", like data bindings or those additional components I see in local mode are simply not available if HANA is my deployment platform? Should I set up another deployment platform and connect HANA simply "as a data source" to Design Studio? Or will updating to Design Studio 1.6 SP4 help, or what do you exactly mean by "updating to SP4 for Design Studio"?

Greetings,

Daniel

Share
10 |10000 characters needed characters left characters exceeded
Tammy Powlas
Jan 04, 2017 at 11:17 AM
0

Hi Daniel,

If HANA is your deployment platform, you will need to install the Design Studio add-on to HANA. Then things should work. If there is no Design Studio add-on installed on HANA, and you make it your preferred mode, I would not expect Design Studio to work.

If they do not work, consider updating to SP4 - if something doesn't work as expected, sometimes patching helps.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 04, 2017 at 11:40 AM
0

Thank you Tammy,

I believe it would not be possible for me to even open Design Studio in HANA mode, if that Design Studio add-on was not installed to HANA. I assume you are referring to what is described in Chapter 3.1.3 in "Administrator Guide: SAP Business Objects Design Studio based on SAP HANA", we certainly have that installed.

I will try SP4, really hope it will help!

Share
10 |10000 characters needed characters left characters exceeded