Skip to Content
A D

Alert Configuration Not Working PI 7.3

Hi,

We have configured alerts in our PI. We tried to send an alert by failing a message but the alert didn't trigger. When we executed RSALERTTEST report, we did receive the alert but without the container variables as this report does not generate container variable. Apart from this the report SXMSALERT_PROCESS_DATA_GET which had to be triggered previously has become obsolete as per help.sap but is there a replacement for this program? If there is no need of a report to run for alerts then why didn't the alert trigger by itself? Kindly help.We have done all the steps mentioned in the available tutorials.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jul 26, 2012 at 02:00 PM

    hi,

    look at the guide one more time especially at the RWB section:

    http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/00e97ba2-85ce-2b10-20bc-bc05cd172154?QuickLink=index&overridelayout=true&37800007184949

    >>>>SXMSALERT_PROCESS_DATA_GET

    no need to use it anymore

    >>>When we executed RSALERTTEST report, we did receive the alert but without the container

    if this is working then I'd say it's RWB config which is missing/wrong,

    Regards,

    Michal Krawczyk

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Michal,

      We had done the following

      1. Created alert categories in ALRTCATDEF

      2. Created alert rules in RWB for the alert categories and ticked both Alert active and suppress multiple alerts.

      3.Clicked yes for Connected to message and provided the details of sender component,Interface Receiver component,Interface,namespace etc.

      4. Selected No restriction in where did the error occur and then added rule.

      Please let me know if any other configuration is to be done. The basis team has already done the SCOT configuration.

  • Jul 26, 2012 at 02:00 PM

    Adarsh,

    Please check the following things. I have recently configured alerts in PI and it worked without scheduling any additional reports.

    • Is your alert rule active? You can check it in pimon=> Configuration and Administration Tab => Common => Alert Rules
    • Check if there are any restrictions in alert rule that prevent alert generation for test scenario
    • Do you see the alerts in Alert inbox in the pimon=>Monitoring => Alert Inbox
    • Is the issue with emails not going out or there are no alerts in the alert inbox at all?
    Add comment
    10|10000 characters needed characters exceeded

    • A D Nageshwar Reddy

      Could you let me know what is the significance of theĀ  parameter Connected to messgae. Currently we have selected Yes here. Should we select Not relevant?

  • avatar image
    Former Member
    Jul 26, 2012 at 02:09 PM

    Dear Adarsh,

    you are getting mail Via report that means SMTP is properly configuredin SCOT.

    There is some thing missing in your java stack.

    please check the alert rule in RWB->alert configuration and "Where did the error occur?" parameter.

    thanks and regards,

    Anup Banerjee

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member A D

      Hi,

      Are you able to see the alerts in your alert inbox. If yes, the alert works fine and the next step would be to check the scot settings where you have to maintain a correct mail host.

      Check the SAPConnect in tcode: sost if you have any mails pending for delivery. An repeat send action can be done on pending mails.

      Thanks,

      Sudhansu