Skip to Content

Error in MOPZ

Hello all,

We did a successful upgrade from EHP4 to EHP5 for our ERP6.0 systems.

Now we wan't to add some extra Technical Usage to our EHP5 systems (from EHP5)

When starting the MOPZ in our Solman we getting the following error state at the "Select Files" tab.

   

System QA1: Predecessor Product Version EHP4 FOR SAP ERP 6.0 defined in SLD!

System QA1: Predecessor Product Version EHP4 FOR SAP ERP 6.0 defined in SLD!

Message no.MOPZ_CHECKS218

How to solve this error?

We've tried somethings but without succes.

Kind Regards

Herman Haan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jul 26, 2012 at 07:29 AM

    Hi

    If feel you are getting this error because there is a mismatching in you system definition in SLD and SMSY. Try to resync the data again in smsy.

    Which version of Solution Manager are you using?

    Best Regards

    Saurabh

    FCI

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 26, 2012 at 10:52 AM

    Hello Herman,

    it seems that the SLD hasn't change the product status of your landscape.

    Maybe you could try the following:

    In SMSY you choose "Other Objects" and then look for the product "SAP ERP ENHANCE PACKAGE".

    In the list you select "EHP4 FOR SAP ERP 6.0" and click on the "Where-used List"-Button

    Now you see where in your landscape the productversion is still in use.

    Hope this works for you

    Regards

    Sven

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 26, 2012 at 10:59 AM

    Hi there,

    The SAP product definition database (PPMS) has got two versions. EHP4 for SAP ERP 6.0 is PPMS 1.0, and "EHP4 for SAP ERP 6.0 / NW 7.01"  is the PPMS 2.0 equivalent.

    So the correct product version is "EHP4 for SAP ERP 6.0 / NW 7.01" .

    Now, the error message you get means that in some tables of your ERP system called the 'product registry', the old product version EHP4 for SAP ERP 6.0 has been written instead of "EHP4 for SAP ERP 6.0 / NW 7.01" .

    The SLD reads information from the product registry, so no ammount of refreshing the SLD will work to set the SMSY right.

    To get rid of this bad product registry entry, you need to login to your ERP system and check with function module OCS_GET_INSTALLED_SWPRODUCTS if your system has got feature entries with PROD_ID 01200314690900000463 (this is the PPMS number  of the bad EHP4 for SAP ERP 6.0 product version) in output table ET_SWFEATURES. Please note down the ID and PROD_ID.

    If these entries are present, they need to be deleted with OCS_SET_INSTALLED_SWPRODUCTS. You would need to enter in the input table IT_DEL_SWFEATURES the PROD_ID and ID you saw in the last step.

    This procedure is risky and is best left to SAP support personnel. But if you feel you can do it, you may go ahead. please don't hesitate to ask if in doubt,.

    Best regards,

    Miguel Ariño

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Miguel Angel Arino Clarke

      After removing the system from the SLD, and from SMSY, and re-registering in the SLD and re-syncing Solution Manager from the SLD I have been able to get by this error! 

      Thanks Miguel for your insight and expertise, it has allowed me to get much further.

      Tom