Skip to Content
author's profile photo Former Member
Former Member

Compensation Mangement

Hello All,

I am stuck up with an issue in CM.

We have a annual increment process which is a fixed component. This will update Infotype 0008 with a

new record after this compensation run.

CM can give output only through a Wage type. As per the current configuration i have assigned basic salary

as the output wage type for this fixed component (annual increment). The increment amount is updating the

basic salary which is not correct. They are giving hike on CTC. the amount has to be distributed accordingly like

BASIC = 50% of CTC

HRA= 50% of Basic etc ....

How can this issue be addressed .

Please help with your valuable suggestions.

Thanks in advance.

Regards,

Pavan

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jul 25, 2012 at 03:31 PM

    Hi Pavan

    If I read your threads, you are maintaining the CTC values in some custom info type and using some user exit you are populating those values in IT0008?

    If yes , then In that user exit only you can develop the above logic i.e 50% is basic pay on CTC and 50% HRA on basic and remaining in some special allowance.

    Also as suggested earlier , the valulation table needs to be configured for your requirement to determine % on Basic and HRA for the each emp CTC amounts , but to do this in standard , the CTC value has to be maintained in IT0008 with a wage type but not in Custom infotypes.

    As I'm not sure about the program you are running in CM and % calculation, it would be easy to understand your requirement if you can share some screens and process steps.

    I hope you can hear back some comments from experts in this area will provide inputs here.

    Best Regards

    Venkata Manikanth

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Pavan

      So If I understand correct , the CM report you are running will only update WT without any specific date?

      If yes, I'm guessing you have to enhance your report might solve your problem as a workaround.

      There might be some other SAP std processe while executing the report which needs to be taken care..

      Can you share the tcode for the report you are working.

      Best Regards

      Venkata Manikanth

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.