Skip to Content
author's profile photo Former Member
Former Member

Modifying Generic Layout to add new tables

Hello,

I am trying to modify a Generic Layout Crystal Reports provided in SDN. I want to ad a new table (OCRD) in Outgoing Payment Crystal Layout.

I have tried various methods but whenever I add a new field into the report area, I don't get any data on the Preview area.

Can anyone please guide me with the proper steps to modify this Generic Layouts for Crystal Reports?

Regards,

Sanil

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 23, 2012 at 02:30 PM

    Hi Sanil,

    What is the reporting database that we are using?

    What is the version you Crystal Reports?

    Have you checked if there is any automatic links being created between the tables which is letting crystal reports from displaying any data. Check if proper joins have been created or not?

    One more thing you can do to check is that in Field Explorer, right click the field inside OCRD table and select "Browse data" and see if any data can be seen in the window that appear next?

    Let me know if that help and update the post with your finding.

    - Bwuser

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 24, 2012 at 08:44 AM

    Hi,

    Thanks for the responses Svein-Erik and bwuser.

    I solved the issue. The problem was CR would always do SMART linking of the new table added. This will mess up the existing links between the tables.

    Solution: Disable Automatic Smart Linking from Crystal Reports Options.

    Goto: File > Options > Database (tab) > Uncheck Automatic Smart Linking.

    Now after adding the new table do the linking between tables as desired.

    Regards

    Sanil

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 24, 2012 at 08:44 AM

    Hi,

    Thanks for the responses Svein-Erik and bwuser.

    I solved the issue. The problem was CR would always do SMART linking of the new table added. This will mess up the existing links between the tables.

    Solution: Disable Automatic Smart Linking from Crystal Reports Options.

    Goto: File > Options > Database (tab) > Uncheck Automatic Smart Linking.

    Now after adding the new table do the linking between tables as desired.

    Regards

    Sanil

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Yes Sanil. This option is always check in Crystal Report for Auto-smart linking, Which always create this kind of problem.

      One of the major problem that this option create is performance issue.

      Glad to know that the issue is solved.

      Bwuser

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.