Skip to Content
author's profile photo Former Member
Former Member

Error displaying report in .Net CrystalReportViewer

Having a big problem with some reports in my Visual Studio developed application. To simplify things, I just created a new project and dropped a CrystalReportView control onto the form. I set its report to one of the ones I'm having a problem with and this is what happens (see below).

This just started happening after I updated crystal references to 13.0.2000.0. Not all reports have this problem. Some reports will display some pages but not others. I just get a white box with a red cross through it.

I'm pretty sure there is something about the .rpt files that this viewer does not like. I fixed one report by changing a report option from Full Page to Fit Page but it only worked on that one report.

In my real application, this is what I see in the viewer.

Capture.PNG (23.0 kB)
Capture.PNG (58.5 kB)
Capture1.PNG (107.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jul 20, 2012 at 09:15 PM

    Make sure you are on SP4:

    http://scn.sap.com/docs/DOC-7824

    If you have CR 10.2 (bundled with .NET 2005), or CR 10.5 (bundled with .NET 2008), uninstall these. Remove the viewer off the form. Remove any references to CR. Check that in the toolbox the viewer referenced is version 13. Re-add the viewer to the form. Re-add version 13 references (viewer should have added them when placed on the form).

    - Ludek

    Follow us on Twitter

    Got Enhancement ideas? Try the SAP Idea Place

    Share Your Knowledge in SCN Topic Spaces

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 23, 2012 at 05:31 PM

    I think I have found the problem. I think there is a bug in the winforms crystalreportviewer.

    We have some formula fields that override Display String in Format Object -> Common -> Display String.

    If the formula is a Number type, and it evaluates to a value, you cannot set display string to empty, ie, ''. You can set it to a space however, ie, ' '.

    If the formula does not evaluate to anything, display string value does not matter.

    Please don't ask why we would override display string to empty on a number formula. I inherited these reports.

    Add a comment
    10|10000 characters needed characters exceeded

    • Good point... This has only been reported a few times, unfortunately the other forum posts were in the previous Forum site and only 6 months of posts were copied over so no way to find them now or what the fix was if anything. Of the roughly 480,000 downloads and only 3 people, that we recall, have run into this issue. Not going to be easy to find the reason why.... but we suspect it's environment related of some kind...

      I don't recall if you tried updating the Video card drivers?

      And as a quicjk test I renamed usp10.dll to *.org in C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86 and previewed a report in .NET IDE and I never got the red X but I did not get a report either. When running the app it load version 1.6 from the Windows folder and the report previewed.

      So I suspect it is something around Usp10.dll or it's dependencies that is causing this issue for you...

      Don

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.