Skip to Content

Strange problem with SPM 3.0 extractors

We are activating SPM 3.0 extractors... we made a copy of the 3.0 delivered objects and started activating all (no customization yet); everything worked fine except for the 2 invoice datasources and payments. The read modules will not generate for the invoices, it takes me to the function module in progress and when I dig into it the include for data is the only one present (LZ_SAprojIVBSAKU01) while the program part LZ_SAprojIVBSAKU02 is blatently missing (same thing with BSIK). So I went to the delivered content and activated it and everything was fine. At this point, I deleted my project and all of its objects and recopied - same issue!! For some reason it is not copying those 2 objects correctly.

As for PAYMENTS, it generates the read module correctly but won't gen the datasource. I have gone in and manually activated the PROJECT_DS abap but it did not change anything.

Any ideas???

Thanks,

Mark

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Jul 24, 2012 at 04:37 PM

    it was an authorization issue - not sure what role was missing though, the client gave me SAP_ALL long enough to re-copy the project. I will try to run a trace with my standard authority and see where it fails. As mentioned in the title, this is a strange problem - every other object copied correctly except for the 2 invoice datasources.

    Payment still does not generate a DataSource, but it seems to just be broken.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.