Skip to Content
0

Application was unable to start correctly (0xc000007b)- saprouter

Jan 02, 2017 at 07:00 AM

494

avatar image

Dear All,

When i was trying to start the SAProuter with the command

saprouter -r -S 3299 -K "p:CN-hostname, OU-00000xxx, OU-SAProuter, O=SAP, C=DE" -V 3

an error message is coming. The error message is like "Application was unable to start correctly (0xc000007b).Click OK to close the application."

Why this error message is coming? I installed JRE,DirectX,.Net in my system. But again and again the error message is showing.

Kindly help me in the current situation.

Regards

Praveen

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Praveen Ninan Alex Jan 10, 2017 at 10:17 AM
0

After proper port forwarding saprouter has started

Share
10 |10000 characters needed characters left characters exceeded
Isaias Freitas
Jan 02, 2017 at 04:27 PM
0

Hello Praveen,

If this is a 32bit saprouter, check out this WIKI page.

If it is a 64bit saprouter, or the issue persisted, please go to the Windows Event Viewer and locate an events related to this error (under the Application logs, or maybe under the System logs).

Then, post the complete event here.

Regards,

Isaías

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Isaias,

Here by i am attaching the error screen from event viewer.

Kindly help.

Regards

Praveen

ev.jpg (117.0 kB)
0

Hello Praveen,

Can you provide a screenshot from the "details" tab as well?

Regards,

Isaías

1

Isaias,

I wrongly tried to install it in D folder. Not started. Then i simply tried installing in C folder. It Works. SAP router starts as per my below comment. But connection is not working.

Regards

Praveen

0
S Sriram Jan 04, 2017 at 06:47 AM
0

Hi Praveen.

Try to update the latest version SAProuter from SMP. and then check the service in windows

BR

SS

Show 2 Share
10 |10000 characters needed characters left characters exceeded

SS,

This is the latest version of SAPRouter. Still the issue persists.

Regards

Praveen

0

SS,

The problem was i installed in D folder. Then after i tried installing in C folder. SAP router is starting ;)

Regards

Praveen

0
Praveen Ninan Alex Jan 05, 2017 at 05:57 AM
0

Hi all,

Issue was partially resolved. Now i am able to start saprouter. But connection is not working.

I checked from different network but still sap gui is not connecting.

Regards

Praveen


1.jpg (78.6 kB)
Share
10 |10000 characters needed characters left characters exceeded
Isaias Freitas
Jan 06, 2017 at 09:50 PM
0

Hello Praveen,

I do not see why the saprouter would not work from the D drive...

Maybe the folders/files did not have the correct permissions? But then I would not expect such crash...

Anyway, I'm glad the saprouter is starting.

Notice that you would need to keep that command prompt window opened. Otherwise, anything connecting through the saprouter will fail.

You can read this WIKI page for assistance with installing the saprouter as a service.

Regards,

Isaías

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Isaias,

Now its working. After proper port forwarding saprouter has started.

Regards

Praveen

0

Nice to hear the good news! :)

Please mark this question as answered, then ;-)

Regards,

Isaías

1