Skip to Content
author's profile photo Former Member
Former Member

Date format in SAP Tables

Hello Experts,

We have a date issue here at work. For some reason, when the tables are downloaded from SE16, the date appears in a numeric format.

I have checked on the blogs and community network as well, but looks like the date issue we have here is quite unique.

Example - Table TCURR - which stores foreign exchange rates displays a random number like 79879898. This is in SAP itself and when downloaded into excel or unconverted list, the number even cant be converted to date format in MS excel. The above date actually represents the date value 01/01/2012 in the OB08 transaction.

We looked at quite a few options - one of them was to write a macro in Excel that will be an addin tool and we use the macro to convert the date format. However though the number 79879898 is way to big and outside the excel numbering convention.

In MB51 download we have a similar issue, but however though the date translates into a 42152 series number. So it falls in the MS excel range and we are able to correct it using the MS excel add in macro.

But the currency table is totally out of range.

Can someone please advice if they have a similar issue and if there is a way to fix the problem?

Its a pain to download tables in SE16. Any work arounds will also be appreciated.

Regards

T

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 26, 2012 at 08:31 PM

    Go to SE16-> TCURR execute-> Go to
    Setting-> Select User parameters-> Enable check conversion
    exits on the data browser tab of user specific settings.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 18, 2012 at 09:11 AM

    Hello T,

    I had a similar issue a couple of month ago. The error in SE16 only occurs, if you save the table to your harddrive (CTRL+Shift+F9) and then open it in Excel. The trick is to directly open the table in excel (CTRL+Shift+F7), the conversion then works fine for me.

    Hope this helps,

    Jann

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.