Skip to Content
0
Former Member
Jul 14, 2012 at 03:39 PM

Identity Center Error: TNS-12557: TNS:protocol adapter not loadable

47 Views

Hi folks,

I'm currently installing SAP NW IDM 7.2 for testing. Here's what I've done so far:

1. Installed Oracle11g (software only)

2. Installed SAP NW 7.3

- during installation, i was asked for the CD of the database client. I provided the CD for Oracle 10.2.0.5 Client

- during installation, SAP JVM was also automatically installed so I no longer installed a JDK in my server

- I also added the /bin folder of the JVM in the PATH environment variable

3. Installed Identity Center Database Schema

4. Installed Management Console

5. Installed Runtime Components

6. Installed Identity Management User Interface

I am now following the Initial Configuration and am currently in step Adding an Identity Center Configuration. When selecting Oracle Provider for OLE DB, I was getting an error that said the provider was not available. Searching the forums gave me an idea that I need to install a 32bit Database Client. I could not find an Oracle 10.2.0.5 32-bit client, so I installed an Oracle 11.2.0.1 32-bit client. I chose the option Custom, and selected Oracle Provider for OLE DB. I indicated a new oracle home here because my original Oracle Home was not being accepted. After this, I was able to select Oracle Provider for OLE DB without any error.

Going back to adding an Identity Center, Selecting Oracle Provider for OLE DB prompted a new window asking me for my the Data Source (my database SID), and the user and password (mxmc_admin), I clicked the button Test Connection, and this is where a new error prompted, saying Test connection failed because of an error in initializing provider.TNS-12557: TNS:protocol adapter not loadable.

Doing a tnsping <database sid>, i got the same error. I checked my environment variable PATH and noticed that the oracle home (the one I used to install Oracle Provider for OLE DB) I indicated was there. As per the document SAP NetWeaver Identity Management Identity Center Installation overview, I removed the 32-bit client from PATH.

Repeating the steps for Adding an Identity Center Configuration, I am still encountering the same error about the protocol adapter not loadable. But when i performed a new tnsping <database sid> again, it was now successful.

Does anyone have an idea how to solve this issue?

Please advise.

Thanks!