Skip to Content
0
Former Member
Jul 11, 2012 at 10:51 AM

BI 4 SP 4 Installation on Linux

146 Views

Dear all,

I am currently stuck in an linux installation for SAP BusinessObjects (in particular I'm trying to install the following package

51043402_SBOP BI PLATFORM 4.0 SP04 (incl. FP03) SERVER LNX 64B)

My env:

CentOS release 5.8 (Final), kernel 2.6.18-308.8.2.el5 x86_64

SQL*Plus: Release 11.2.0.3.0

Java(TM) SE Runtime Environment (build 1.6.0_33-b03)

Perl v5.8.8 built for x86_64-linux-thread-multi

My prob:

Whenever I run ./setup.sh InstallDir=/usr/local/sap_bo as user sapbo (in wheel group)

I receive strange perl errors:

[sapbo@sap2 BusinessObjectsServer_lnx]$ ./setup.sh InstallDir=/usr/local/sap_bo

/tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setupexe InstallDir=/usr/local/sap_bo

[Error] (in cleanup) Can't locate unicore/PVA.pl in @INC (@INC contains: /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/setuplibs/../../actions/Uncategorized /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/setuplibs/../../shared/ActionContext /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx//setup.engine/setuplibs /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/5.8.9/x86_64-linux-thread-multi /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/5.8.9 /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/site_perl /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/site_perl/5.8.9 /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/site_perl/5.8.9/x86_64-linux-thread-multi /build/psbuild/rel32/linux_x86/release/bin/tp.perl/5.8.9/lib/5.8.9/x86_64-linux-thread-multi /build/psbuild/rel32/linux_x86/release/bin/tp.perl/5.8.9/lib/5.8.9 /build/psbuild/rel32/linux_x86/release/bin/tp.perl/5.8.9/lib/site_perl/5.8.9/x86_64-linux-thread-multi /build/psbuild/rel32/linux_x86/release/bin/tp.perl/5.8.9/lib/site_perl/5.8.9 .) at /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/5.8.9/utf8_heavy.pl line 97.

[Error] Can't locate ShowDialog.pm in @INC (@INC contains: actions /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/setuplibs/../../actions/Uncategorized /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/setuplibs/../../shared/ActionContext /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx//setup.engine/setuplibs /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/5.8.9/x86_64-linux-thread-multi /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/5.8.9 /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/site_perl /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/site_perl/5.8.9 /tmp/_sap/SBOP_BI_4SP04/DATA_UNITS/BusinessObjectsServer_lnx/setup.engine/perl/lib/site_perl/5.8.9/x86_64-linux-thread-multi /build/psbuild/rel32/linux_x86/release/bin/tp.perl/5.8.9/lib/5.8.9/x86_64-linux-thread-multi /build/psbuild/rel32/linux_x86/release/bin/tp.perl/5.8.9/lib/5.8.9 /build/psbuild/rel32/linux_x86/release/bin/tp.perl/5.8.9/lib/site_perl/5.8.9/x86_64-linux-thread-multi /build/psbuild/rel32/linux_x86/release/bin/tp.perl/5.8.9/lib/site_perl/5.8.9 .) at (eval 5) line 2.

BEGIN failed--compilation aborted at (eval 5) line 2.

A locate on PVA.pl reveals

[sapbo@sap2 BusinessObjectsServer_lnx]$ locate PVA.pl

/usr/lib/perl5/5.8.8/unicore/PVA.pl

Anybody an idea how to resolve that issue?

I installed Edge BI 3 SP 3 and SP 3 without any problems on CentOS 5.8 however BI 4 seems to be a blocker.

Any suggestion is highly appreciated.

Best rgds

Attachments