Skip to Content

Anonymizer bean is used, but the namespaces are not changed.

Hi All,

I have attached the Actual SOAP.xml(Expected Soap file) and the PresentQSOAP.xml(my output file).

The namespaces are different, i tried it using anonymizer bean but i am not getting the correct namepaces

Please let me know how to do it, any help will be appreciated.

Regards,

Sreenivas

Actual SOAP.xml (1.3 kB)
PresentQSOAP.xml (4.2 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Jul 10, 2012 at 08:03 AM
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 10, 2012 at 10:25 AM

    Hi,

    Just wanted to ask, are you using a SOAP adapter on sender side. If yes, anonymizer bean will not work as Sender SOAP adapter does not support any adapter modules. I have an XSLT mapping as below, which I tried to modified as per your requirement but you may need to refine it further:

    <?xml version='1.0' encoding='utf-8'?>

    <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

    <xsl:template match="/*">

    <ns0:QSOAP_Final xmlns:ns0="http://www.quadrem.com/soap/">

    <xsl:copy-of select="//HEADER" />

    <xsl:copy-of select="//BODY" />

    </ns0:QSOAP_Final>

    </xsl:template>

    </xsl:stylesheet>

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 10, 2012 at 11:29 AM

    Seenu,

    Please note the following points:

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 10, 2012 at 11:48 AM

    H Seenvu,

    You can mark the option Do not use SOAP envelope in the communication channel and later to remove all the namespaces in the operation mapping with this xsl:

    <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

    <xsl:output method="xml" indent="no"/>

    <xsl:template match="/|comment()|processing-instruction()">

    <xsl:copy>

    <xsl:apply-templates/>

    </xsl:copy>

    </xsl:template>

    <xsl:template match="*">

    <xsl:element name="{local-name()}">

    <xsl:apply-templates select="@*|node()"/>

    </xsl:element>

    </xsl:template>

    <xsl:template match="@*">

    <xsl:attribute name="{local-name()}">

    <xsl:value-of select="."/>

    </xsl:attribute>

    </xsl:template>

    </xsl:stylesheet>

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.