Skip to Content
0

PowerDesigner : Column Order in Database Syncronization

Dec 31, 2016 at 10:26 AM

121

avatar image
Former Member

Hi,

When I apply the PDM changes to Database ( Choice Menu - > Database - > Apply Model Changes to Database ) I would ignore the warning that the columns of a database table are not in the same order as in the PDM.

I don't found any point in the Database Syncronization Dialog Windows to ceck "Ignore columns order"

Is it possible configure PowerDesigner for not view this warning ?

Thanks

Alberto.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

George McGeachie Jan 06, 2017 at 09:29 AM
0

Hello Alberto

You can change the comparison options, so that the order of columns in a table is ignored. Take a look at the Help Topic "Excluding Objects and Properties from a Compare or Merge".

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 10, 2017 at 08:04 AM
0

Hello George,

first of all thanks and happy new year.

I had looked at what you show me but I have not found what I need to set to ignore the sort order.

I had looked in Table Options or in Column Options

You know what voice I have to set ?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 10, 2017 at 02:21 PM
0

Hi Alberto,

what George is saying - in the merge dialog window, you can deselect the "order" option for columns:

BR,

Rafal


8iez7.png (58.6 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 11, 2017 at 09:23 AM
0

Ok ..thanks to all

have a nice day

Alberto

Share
10 |10000 characters needed characters left characters exceeded
George McGeachie Jan 11, 2017 at 12:33 PM
0

Thanks for taking the time to include a screen shot, Rafal. I was in a rush :)

Share
10 |10000 characters needed characters left characters exceeded