Skip to Content
avatar image
Former Member

SMQ2, Connection closed (no data)

Hi Experts,

We have JDBC to proxy scenario. While testing this interface we are getting CPICER - connection closed(nodata) error. This interface was working fine earlier.

RFC destination and authorizaion check also fine. Deleted the queue and send again and checked. Its remain same.

Any suggestion ?

Thanks in advance.

Regards,

Naushad Shaik

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jul 06, 2012 at 03:10 PM

    Hi Naushad,

    This is generally due to network connectivity issue.

    Wait for some time and go through the below note -

    Note 335162 - Error "connection closed" in tRFC/qRFC monitors

    Also as per the SAP Note - 378903

    During transmission or processing of the first LUW in the target system, a network or communication error occurred. When you double-click on this status, the system displays an error text. For additional information on this error, refer to the dev_rd or dev_rfc* trace files in the syslog (transaction SM21). being referred for to dev_rfc*. Depending on the registration of this queue (SMQR), a batch job is scheduled for repetition. Refer to note 369524 for the error text "R/3 logon failed".

    Status CPICERR may also exist in the following cases although no communication error occurred: A qRFC application finds out that a LUW cannot be processed any further due to a temporary error in the application and therefore calls the RESTART_OF_BACKGROUNDTASK function module in order to prompt the qRFC Manager to cancel the execution of this LUW and to repeat this LUW later in accordance with the specification in transaction SM59. In this case, qRFC simulates a communication error with the text "Command to tRFC/qRFC: Execute LUW once again.". If this error occurs very often, you must contact the corresponding application.


    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 09, 2012 at 05:21 AM

    We restarted our server still the problem remain same (connection closed). When I tryed to execute the LUW, I got information message "Target system/gateway not active". Any other suggestions experts?

    Thanks,

    Naushad Shaik

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Naushad,

      Sorry for a delayed response.. Hope your problem has been resolved..

      If not i would suggest you to look into the connectivity issue as i said earlier..

      Also, as you said in your above post there can be problem with your Proxy so please confirm the same.. but i don't think it will be an issue

      Thanks,

      Kalyan