Skip to Content
avatar image
Former Member

Assembly XML problem with 6.0.3.0

Hi,

When trying to assemble INVENTORY_ID with xml -message I get following error:

<PRODUCTION_RESPONSE><ASSEMBLE_COMPONENTS><INVALID_IDENTIFIER_LIST><INVALID_IDENTIFIER>TSM01006</INVALID_IDENTIFIER><REASON_FOR_ERROR>Required value "Inventory ID" missing; enter a value in the Inventory ID field (Message 10015)</REASON_FOR_ERROR></INVALID_IDENTIFIER_LIST></ASSEMBLE_COMPONENTS></PRODUCTION_RESPONSE>

exactly similar mesage works with 5.2. However assembling the same INVENTORY_ID with POD goes fine.

My colleague tried with webservices and got the error response as well. Is this some known issue at the moment?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jul 06, 2012 at 07:53 AM

    Hello Petri,


    Please, try an XML request with <ASSY_DATA_VALUES> tag, which stands for the assembly data that needs to be collected. You may use a template below:

    <PRODUCTION_REQUEST>
    <ASSEMBLE_COMPONENTS>
    <USER></USER>
    <SITE></SITE>
    <PARENT_SFC></PARENT_SFC>
    <OPERATION></OPERATION>
    <RESOURCE></RESOURCE>
    <CHECK_OPER></CHECK_OPER>
    <EVENT></EVENT>
    <IDENTIFIER_LIST>
    <IDENTIFIER_OBJECT>
    <IDENTIFIER></IDENTIFIER>
    <REVISION></REVISION>
    <QTY></QTY>
    <REF_DES></REF_DES>
    <LOCATION></LOCATION>
    <ASSY_DATA_VALUES>
    <ASSY_DATA>
    <DATA_FIELD></DATA_FIELD>
    <DATA_ATTR></DATA_ATTR>
    </ASSY_DATA>
    </ASSY_DATA_VALUES>
    </IDENTIFIER_OBJECT>
    </IDENTIFIER_LIST>
    </ASSEMBLE_COMPONENTS>
    </PRODUCTION_REQUEST>

    And update us on your results.

    Best regards,

    Alex.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Petri,

      The idea is the same: you have to specify the correcsponding tags correctly:

      <me:AssyDataValue>
      <me:Attribute languageCode="?">?</me:Attribute>
      <me:Value languageCode="?">?</me:Value>
      </me:AssyDataValue>-->

      where Attribute is the name of the field to be collected and the Value is for its value (in your case for Inventory ID).

      Hope it helps. Please update me on your results.

      Best regards,
      Alex.

  • Jul 05, 2012 at 11:36 AM

    Hello Petri,

    Can you retrieve that Inventory in Maintain Inventory activity?

    Can you export that Inventory by EXPORT XML request?

    What is the value of 'Allow Remote Legacy Access' System Rule?

    Is it Inventory specific problem and did it work fine before?

    Regards,

    Alex.

    Add comment
    10|10000 characters needed characters exceeded