Skip to Content

ABAP in Eclipse Installation Error

I am trying to install ABAP in Eclipse and getting below error.

does any one any idea how to resolve it.

Cannot complete the install because one or more required items could not be found.

Software being installed: ABAP Development Tools - Core 1.0.2 (com.sap.adt.tools.feature.group 1.0.2)

Missing requirement: ABAP Development Tools Communication Framework 1.0.2 (com.sap.adt.fwk.ci.feature.group 1.0.2) requires 'org.eclipse.mylyn.commons.feature.group [3.4.3,4.0.0)' but it could not be found

Cannot satisfy dependency:

From: ABAP Development Tools - Core 1.0.2 (com.sap.adt.tools.feature.group 1.0.2)

To: com.sap.adt.fwk.ci.feature.group [1.0.0,2.0.0)

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    Jul 04, 2012 at 10:14 AM

    Got it Fixed. Some Packages were missing, Installation is successful.

    But since we don't have SAP Netwaver 7.31 cannot connect to SAP Backend. 😔

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      we have the same issue. it appears that support starts at 7.03... naturally, we are at 7.02. I continue to find it frustrating to not have access to new tools because our environment does not allow us to do updates so often... but whose does?

      how did they pick 7.03 as the baseline? what is in 7.03 that is NOT in 7.02?

      so again, another tool that i will not get to use. pardon my absolute frustration.

  • Jul 04, 2012 at 12:45 PM

    Hi Khalid,

    you can try it out with the SAP NetWevaer 7.03 SP4 Trial:

    http://www.sdn.sap.com/irj/scn/downloads?rid=/library/uuid/30a6dbb2-a774-2e10-ee83-9f6432973545

    Best Regards,

    Olga.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 05, 2012 at 12:34 PM

    Hi Khalid,

    how did you fixed your problem of your missing Packages?

    I am getting the same issue.

    Cannot complete the install because one or more required items could not be found.

    Software being installed: ABAP Development Tools 1.0.3 (com.sap.adt.core.feature.group 1.0.3)

    Missing requirement: ABAP Development Tools Connectivity 1.0.2 (com.sap.adt.connectivity.feature.group 1.0.2) requires 'org.eclipse.platform.feature.group [3.6.0,4.0.0)' but it could not be found

    Cannot satisfy dependency:

    From: ABAP Development Tools 1.0.3 (com.sap.adt.core.feature.group 1.0.3)

    To: com.sap.adt.connectivity.feature.group [1.0.2]

    Regards,

    Awadhesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 27, 2012 at 08:21 AM

    My installation is done. but at the creation of project i'm getting an error 😕

    "An error has occurred. See error log for more details.

    com/sap/mw/jco3/eclipse/Registry "

    Please help if you have any idea to solve

    Add comment
    10|10000 characters needed characters exceeded