Skip to Content
author's profile photo Former Member
Former Member

How to enable 'Don't Summarize' for chart value when using xsd file as dataset.

Hello Friends,

I have a chart which is getting its values form a .xsd DataSet created in VS 2010. (I am using CR 13 for VS 2010). the DataSet have two columns first is 'datetime' which is my conditional field and second is 'value' which is summarized field. 'datetime' is of System.DateTime type and 'value' is of System.Decimal type. I am binding this chart at runtime.

I want to use default value from 'value' field and do not want to summarize it. But the Don't Summarize option is disabled in Chart Expert.

Please tell me how can I enable this option and get default value for my field.

Thanks in advance.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Jul 04, 2012 at 08:59 PM

    I'd recommend downloading of CR 2011 eval for this issue and many of the other issues regarding report display you posted recently. Open your reports in CR 2011, test them there, making sure they work as desired, then run them in CRVS2010. Also, CR 2011 includes a more extensible chart expert that may help with the chart issue.

    CR 2011 eval can be downloaded here:

    http://www.sap.com/solutions/sapbusinessobjects/sme/freetrials/index.epx

    - Ludek

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ludek and all,

      I have found a similar thread here: (I don't know how I missed that)

      http://scn.sap.com/thread/910004

      And tried the suggestion posted in that thread and created a formula field for my value field and used that formula field at the place of value field.

      numberVar values := {Dataset1.value}

      Now I am able to check "Don't Summarize" option . That solution worked for me. The only problem is that now the formula is giving result in round figure. (e.g. 10.99 to 11).

      Thanks.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.