Skip to Content
avatar image
Former Member

Messages not getting pushed to ECC from PI although not in Error

Hi All,

The messages pushed from 3rd party systems are coming into SAP PI system but these are not getting pushed from SAP PI to SAP ECC although these are not in error status.

The real-time messages comes into PI daily. But for few days got failed(because of insufficient database table space), then I reprocessed them. 90% of them got reprocessed and flown to ECC successfully. Now these remaining 10% messages got stuck into queues and showing status as "ready" in outbound queue and "running" in inbound queue.

Because of these the daily real-time messages also got stuck into queues and not getting processed since last 20 days.

Inbound Queue

Outbound Queue

What I need to do in this? Please guide me in this urgent/critical issue.

Thanks & Regards,

Amit S Patil

Inbound-1.jpg (72.4 kB)
Inbound-2.jpg (224.8 kB)
Outbound-1.jpg (73.3 kB)
Outbound-2.jpg (223.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jul 04, 2012 at 06:57 AM

    Hi,

    double click on the message in queue to get redirected to SXMB_MONI

    get the message from there and test on test system if it works over there

    Regards,

    Michal Krawczyk

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Amit,

      this looks like a binary payload which is illegal and cannot be interpreted by the system. I think the safest would be to cancel those messages and send them again cleanly, if required.

      The disk space problem could be the reason for this. Maybe the system couldn't persist the payload.

      Regards,

      Jörg