Skip to Content
0

anyone know how to configure "messaging memory"

Dec 30, 2016 at 02:27 PM

114

avatar image

Hi, we are using Active Messaging feature from ASE to send message to MW server but we keep having this error:

msgno 15101, sev 17, state 2: 'There is insufficient memory to allocate 1 bytes. Please increase configuration parameter 'messaging memory', or try again when there is less activity on the server.

We have increase to memory many times but the error always coming back. So, I can I figure the value I should configure this parameter? Any hints?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Mark A Parsons Dec 30, 2016 at 03:04 PM
0

NOTE: I don't work with Active Messaging, but fwiw ...

From the write up for error 15101 in the ASE 16 Troubleshooting guide:

If the number of bytes to be allocated is higher than expected, check the application to make sure the message sizes are not excessive. If the state is 1 or 3, increase “messaging memory.” If the error is raised with state 2, increase the “heap memory per user.”

Your error message is showing state = 2; have you tried increasing heap memory per user?

See the ASE 16 System Admin Guide (Vol 1) for details about the heap memory per user configuration parameter.

Share
10 |10000 characters needed characters left characters exceeded
Francois Asselin Dec 30, 2016 at 06:12 PM
0

thanks for your answer.

yes I have increase the heap memory per user and messaging memory but the problem comes back. Every time, I increase the memory but I would like to set the parameter to the right number number so I don't have error anymore in my production environment.

I konw I can set the value very high but I don't want to waste memory.

Share
10 |10000 characters needed characters left characters exceeded
Mark A Parsons Dec 30, 2016 at 06:39 PM
0

You've haven't mentioned what values you've set for various config parameters, so it's hard to tell if your values are too low, too high, or if there's a bug.

For example, the admin guide recommends setting heap memory per user to 3x the logical (aka dataserver) page size. What is your dataserver's page size? What value have you tried setting for heap memory per user?

If you're unable to find, via trial and error, settings for heap memory per user and messaging memory then I'd suggest opening a case with tech support; tech support can likely provide some guidelines for these config values and/or let you know if there's a bug with your version of ASE and active messaging.

Share
10 |10000 characters needed characters left characters exceeded
Avinash Kothare Jan 03, 2017 at 04:17 PM
0

What version of ASE?

Do not increase heap memory beyond certain limit (64K per user if I recollect correctly from our incident/case). We faced a similar issue in a different context. Our login trigger caused memory fragmentation and a kind of memory leak. When available free chunks in memory dropped below a certain limit each query failed and we had to reboot the server.

So open/log a case with SAP. If you can simulate the error in a predictable manner, you can request what is called a one-off or go for the latest SPx/PLxx as SAP may recommend.

HTH

Avinash

Share
10 |10000 characters needed characters left characters exceeded
Nicolas Pilboue Feb 28, 2017 at 09:53 AM
0

Hello François,

Did you solve the issue "There is insufficient memory to allocate 1 bytes. Please increase configuration parameter 'messaging memory', or try again when there is less activity on the server."

We encounter the same error on ASE16 RTDS...

Thanks for your help,

Nicolas

Share
10 |10000 characters needed characters left characters exceeded