Skip to Content
author's profile photo Former Member
Former Member

Issue with Adaptive Webservice model Execution

Hi,

I have created an "Adaptive Webservice Model" which is a WSDL file from PI server. This is the synchronous communication. I will set a parameter during the execution of the model and I will get a return value from the PI Interface.

This was working fine and I was able to receive the parameter. but suddenly (Without any changes to the code), the model execution is not happening. I have checked the user ID maintained in the "DynamicWebserviceProxy" and everything is fine with it. No changes was happened anywhere in the system both portal and PI. But the model exection was not working anymore.

coding has been done as follows.

1. Execution of model.

2. Get the parameter from PI interface.

3. set the parameter value to the local attribute in the context.

The execution of model is within TRY - CATCH block. If there is a problem with execution of model, I should get some exception in catch block.

But there is a "Nullpointerexception" during the 2nd step. i.e. Getting the parameter from the PI interface.

When I check the portal log there is no log for execution step using the "DynamicWebserviceProxy".

Also there is no log in PI logs & traces.

Pls throw me some light on how to locate where the issue is.. I didnt do any changes to the codings and suddenly it throws the exception.

Is there any way I can trace what is happening when i run the model.

give me some idea on this.

Thanks,

Mahendran B.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Jun 26, 2012 at 11:18 AM

    Hi Mahendran,

    Sometimes some WebService calls may fail if you dont supply all fields i.e. if there is String field supposed to be left blank, fill it with a "" character. A Null Pointer exception means that some field has been read that holds a null and this field should be a class references type like String. I have mostly seen this kind of issues when you try to do manipulation a String reference while it is set to null.

    Most likely your problem should be solved by trying the following steps -

    1). mock call your web Service through a Web Service call simulation tool like Soap UI

    2). try filling all your blank strings with "" character

    3). make an instance of all necessary structures that are provided in the model.

    4). double check if you are filling the right input in the right structures.

    Regards,

    -Amol Gupta

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Mahendran,

      If it is running from SOAP UI, it should work fine from Web Dynpro as well.

      Make another demo project, separate from the one you have been working on and check it by creatign a model, you can skip visual admin config for the demo project. If separate demo project works then you may have to delete your existing model and recreate model in the original DC/Project.

      Also, double check if you are putting the right data in the right context.

      Regards,

      -Amol Gupta

  • Posted on Jun 26, 2012 at 02:59 AM

    your system version?

    debug first

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.