Skip to Content

No service found for namespace /PARTNERNAMESPACE/, name SERVICE

Hi experts,

I'm having some problems working with SAP NW GW 2.0 and I thought that may be you could help me. Basically, I'm developing Gateway Services based on the article [Content Deleted June 2013] ( How To... Create a Gateway Service Using the RFC Generator - Advanced Scenario) published by Jin Shin, and I'm getting the following error when I'm calling the service in my browser:

<code>SY/530</code>

No service found for namespace /PARTNERNAMESPACE/, name SERVICE, version 0001

If I check the /IWFND/ERROR_LOG I got the following:

Nur 'Fehl.' messages of this request will be logged /IWFND/CM_LOGGING007 An exception has occurred SY530 An exception has occurred SY530 Exception of type /IWFND/CX_SODATA has occurred. See details for more information /IWFND/CM_LOGGING006 Exception of type /IWCOR/CX_DS_INTERNAL_ERROR has occurred. See details for more information /IWFND/CM_LOGGING006

Note: the namespace "PARTNERNAMESPACE" is illustrative, I'm working for one and that's why I put it like that. I think that it may be relevant.

In the project that I'm working we have an special "Namespace" to develop so we don't use "Z" or "Y". So, when you deploy the services following Jin Shin tutorial you ended up getting these services under that namespace in the SICF. Initially, when I got this error I checked in the SICF if the service was active or any other upper nodes finding that the path to the service is perfectly right and active: /sap/opu/odata/partnernamespace/service

I decided to recreate the service in the regular namespace for custom objects (Z*) to verify if something was "off" with the other namespace, and to my surprise the service does work without any problem there (as a local object: $TMP). The path is exactly in the same conditions (active) like the other one: /sap/opu/odata/sap/zservice

Using the /IWFND/TRACES I noticed the following difference between the "Successful Call" to the zservice and the "Failed Call" to the /PARTNERNAMESPACE/SERVICE :

Status OK

1
1 Gateway Data Provider Delegator /IWFND/CL_MGW_PROV_DELEGATOR GET_DATA_PROVIDER 14 14 2

Local DP Data Provider /IWFND/CL_ODC_COE_RT_MANAGER GET_ENTITY 138 138 3

Gateway OData Lib 1.0 Integration /IWFND/CL_SODATA_MAPPER GET_ENTITY_PROV_BY_FEED_DATA 28 28

Status ERROR:

1
1 Gateway Data Provider Delegator /IWFND/CL_MGW_PROV_DELEGATOR GET_DATA_PROVIDER 1 1 2

Gateway OData Channel Remote Connectivity /IWFND/CL_MGW_RUNT_RCLNT_UTILS XML-Serialization

3

Gateway OData Channel Remote Connectivity /IWFND/CL_MGW_RUNT_RCLNT_PRXY Call Remote BEP 25 25

It seems that both goes for the Data Provider but the one that fails can't reach it.

The Technical Information of the system where we're working is the following:

GW_CORE 200 0003 SAPK-20003INGWCORE SAP GW CORE 200 IW_BEP 200 0003 SAPK-20003INIWBEP Backend Event Provider IW_CBS 200 0002 SAPK-20002INIWCBS SAP IW CBS 200 IW_CNT 200 0002 SAPK-20002INIWCNT SAP IW CNT 200 IW_FND 250 0003 SAPK-25003INIWFND SAP IW FND 250

I think that there is a problem related with the automatic generation of code/objects when it takes place under a Partner Namespace but I couldn't find how to fix it.

Hope you can help me, every effort would be more than welcome.

Thanks!

Best regards,

Diego Dora.

Message was edited by: Jason Lax

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 10, 2012 at 02:31 PM

    Hi,

    I am having the same issue as Diego. Was this problem resolved?

    Yohan

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 26, 2012 at 07:43 AM

    As a follow up - Still not answered/resolved. Any help would be appreciated.

    Thanks!

    Diego.

    Add comment
    10|10000 characters needed characters exceeded