Skip to Content
0

SAP HANA 2.0 Express Edition - Where are the HANA Run-time tools?

Dec 30, 2016 at 07:44 AM

410

avatar image
Former Member

I installed HXE 2.0 and I can't find the HRTT. I can run the Web IDE and build something but that is it. I can run the "Hello-World" program with the button that can be pushed from the Web IDE, so I guess the DB itself works.

Also I wonder why I can't make the database backup appear. Same goes for creating users. There is no "backup" role shown as a tutorial here suggests.

Somehow I feel I do something wrong...

Any ideas? It runs as a VM.

Gunter

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Florian Pfeffer
Dec 30, 2016 at 10:01 AM
0

The "HANA Runtime Tools" were renamed to "Database Explorer". Beside the standalone application it is integrated also as perspective in the Web IDE for SAP HANA.

You can check

for more details.

For the other two things (backup, user creation) please share more details for the issues you have.

Regards,
Florian

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 01, 2017 at 04:14 AM
0

Good day Florian,

thanks for clarification, alright, I can access the Database Explorer by calling it directly. However, there is no menu inside the Web IDE, so I think something is really wrong with authorizations. I didn't play around with them so I just took what came out of the box.

Situation is:

1. I log in with XSA_DEV into Web IDE: I can develop but see no database explorer

2. I log in with XSA_ADMIN into Web IDE: I get "forbidden" as a screen. So I need to login to "SAP HANA Cockpit" and log out to be able to log in again with XSA_DEV

3. With XSA_ADMIN I can access the database tools but I'd love to see the table that I created in the tutorial (Purchase orders) of course that I can't as it's not the same user.

As for the backup I simply can't find the screen as shown in the tutorial, also here I believe it might be that the users are not having proper authorizations? If you need any screenshots etc let me know.

Gunter

EDIT: Backup issue solved, found it in the HANA Cockpit! The tutorial refers to XS 1.0 where Backup appears as a tile while in XS 2.0 seems to be only a link below "Administration"->"Manage database backups"

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 01, 2017 at 05:53 AM
0

Ok, making slight progress, I watched this Video, which should be a link in the setup procedure: https://www.youtube.com/watch?v=PJFanAANBWc

However, I can't get to the space management ("Permission denied") with the XSA_ADMIN and the WebIDE shows errors for the plugins when starting up.


Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Gunter,

I'm not sure we have the same trouble, but we could to get sure if you compare my post with yours.

https://answers.sap.com/questions/94678/sap-hana-20-db-explorer-is-empty.html

But maybe I came across to your problem, when I used Mozilla instead Chrome.

Usually I use only Chrome, but to get sure that our problem has nothing to do with the Chrome browser, I checked it also with Mozilla. After starting the WebIDE with Mozilla I realized that a lot of plugins weren't installed and I was also missing the "cube" icon on the left to get the "db explorer" started. Even so there was no link in the menu.

BR,

Dirk

0
avatar image
Former Member Jan 05, 2017 at 02:03 AM
0

Hi Dirk,

for me the issue was with enabling the space (which I named "DEV" like in the tutorial). Once it was enabled the errors disappeared. I use both Chrome and Mozilla and it's fine now.

For your issue let me answer in your thread. Honestly - coming from the stable SAP Netweaver world - the HANA XSA looks like a lot of trial and error. But this is my very subjective view as I'm a newbie :-)

Share
10 |10000 characters needed characters left characters exceeded