Skip to Content
1
Former Member
Jun 08, 2012 at 11:23 AM

Billing Batch RV60SBAT: invoice mail output not processed

585 Views

Hello everyone,

I identified an issue when our billing batch RV60SBAT is processed: sometimes, one of the output type (invoice mail output) is not processed after the creation of the billing document, although all the condition of its processing is met. The ouput is only processed if i enter in the billing doc in VF02 and save it.

I identified that the error depends on a very specific pattern:

If the billing batch creates two billing documents for the same customer in sequence:

A)

  1. billing doc related to a regular sales order: invoice mail output to be generated
  2. billing doc related to an aftersales return: no invoice mail document to be generated

The invoice mail output type will not be generated for the billing doc 1 B)

  1. billing doc related to an aftersales return: no invoice mail document to be generated
  2. billing doc related to a regular sales order: invoice mail output to be generated

The invoice mail output type will be generated for the billing doc 1 even though it is not required.

The invoice mail output type will be properly generated for the billing doc 2

It seems SAP applies the output type of the next document to the current one.

Output type of document 2 is applied to document 1

Output type of document 3 is applied to document 2

Output type of document 4 is applied to document 3

Etc.

My first question is: do you think my diagnosis is correct and have you ever seen this kind of bug in the billing batch RV60SBAT?

I am trying to find a way to sidestep the problem. Do you know if there is a way to separate invoicing by sales document type in the standard batch program RV60SBAT?

Thank you in advance for your precious help.

Oliv