Skip to Content
avatar image
Former Member

Import server not picking file from Import Ready folder

Hi Experts,

PI is placing an xml(file A)  file in MDM ready folder. But MDIS is not picking up that file.

File permissions are fine. MDIS is running fine. Ports, schema and import maps are assigned fine.

Also, when I am placing any other xml file, that file is atleast pickedup by MDIS and sent to exceptions.

But it is not picking file A.

Please help

Regards,

Rajeev

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 08, 2012 at 10:29 AM

    HI Rajeev,

    I am assuming here that you do not have any file in structural exception so that it won't hinder the movement of the file.

    Can you please check if any user is connected to the port while this auto import is being executed?

    Case may be that connection to Port through Import manager is hindering the auto imports.

    As a workaround, can you please unload the repository while this file is in ready folder and then load repository with Indices again. When i faced such situation, then this workaround always worked.

    Another workaround that SAP recommends is to rename the file in Ready folder.

    Renaming did not work out during my issue but Repository reload did the trick always.

    Kindly check and let me know the results.

    Thank you.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Rajeev,

      Thanks for the update. So the issue is resolved now. And you had mentioned that files are going to exception folder. Since you have corrected the format of XML, it should now pass without exception.

      But in case it still goes into Structural exception, then you should check that no source record should have "Space" appended to the data value. Best way to check this is to open file in Notepad and check for random values. Extra spaces make it difficult for system to interpret values correctly and system is stressed while auto imports leading to unknown exception. So you can check this one thing if you still face structural exceptions. Also kindly close the thread as issue is solved.

      Thanks and Regards,

      Ankush Bhardwaj

  • avatar image
    Former Member
    Jun 08, 2012 at 10:31 AM

    Hi,

    Please check MDIS logs for detail. Also try to reset the password of MDIS in console & check again.

    If it doesn't work go for MDIS server restart.

    Please revert with your result.

    Regards,

    Gaurang

    Add comment
    10|10000 characters needed characters exceeded