Skip to Content
avatar image
Former Member

XML PO output transmission error

Hi,

We are on SRM 7.1.

I have a PO for which the XML trasnmission had failed.The output log in the PO screen shows "incorrectly processed".

Where can I check the error log for this PO to determine what was the cause for this XML transmission failure?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jun 08, 2012 at 12:52 AM

    Have you checked the XML message in XSMB_MONI for the error status of the XML message.

    With Regards,

    Malay

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 08, 2012 at 02:40 AM

    Hello,

    Did you look into txn sxmb_moni or sxi_monitor in the receiving system or the connected PI system?

    XML doesnot fail normally in the sending system or if it fails you cant find it in the sxmb_moni.

    I am assuming you are trying to send the PO to SUS via XML as only this is shown in output tab.

    If it has failed in PI, it is probably due to failed receiver determination.

    If it has failed in SUS, then you need to check in the above txn if there was any technical error.

    For any config errors like missing business partner , number range issues etc... PO will be transferred to FEH if you have activated it.

    Please refer to following link for more details on FEH

    http://scn.sap.com/community/pi-and-soa-middleware/blog/2011/02/24/pixi-forward-error-handling-feh-for-asynchronous-proxy-calls-with-the-use-of-error-and-conflict-handler-ech

    Refer to Note 1270081 - Trouble shooting SOA Services for SRM specific information

    If you have not activated FEH, you will have to drilldown into payload of the XML in sxmb_moni to check the log for XML processing and all errors are mostly logged.

    Let me know if this helps.

    Regards,

    Sushil.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello,

      Does the PO XML Output status remain "incorrectly processed" for all the POs?

      Can you check the log and determine if some warnings or errors are there?

      Does the PO XML reach the XI system? Check in TXN SXI_MONITOR in XI system.

      Please try to reprocess the PO XML output in Output tab and check if the status changes.

      Regards,

      Sushil.