Skip to Content
author's profile photo Former Member
Former Member

#Datasync Issue

Hi guys,

I am new to BO,so let help me.

I am trying to create a report with “Merged Dimensions” from 2 separate Universes. I merged the dimension on a common data element and created details of the remaining columns to include in the report. However it seems that even though the dimensions are merged, it does not like to take the objects from the different universes even though the object types are Details

Code:
Location Code Location Name Customer ID
101 ARL 1
101 ARL 2
102 RES 1
103 STR 2 Code:
Customer ID Service Code
1 AC
1 BC
2 CC
2 AC
1 ZZ



Please note in query 1, Customer 1 belongs to two locations – ARL and RES. Similarly Customer 2 also belongs to two locations ARL and STR. ARL is the common location for both customers.

Query 2 shows different services the customers got. There are also services that are common to different customers (same service can be provided to different customers).

For this I created 2 queries and merged the dimensions on “Customer ID”. Then I created variables with type as “details “ for rest of the columns “detail Location Code”, “detail Location Name” and “detail Service Code” and associated these details to their original dimensions.

In the report, when I include the merged dimension along with detail from one single query belonging to one particular universe, they are okay however when I throw the detail object from another query belonging to another universe I get 1 row with “#DATASYNC” in all the columns.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2012 at 08:18 AM

    Hi Jenny,

    whenever I put detail object in from another query and get a line of #DATASYNC

    If I highlight the report objects in the edit report screen and then go to the properties tab and expand the general option, there is a check box called 'Avoid duplicate row aggregation' if you check it your report should then return the results.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.